Quantcast
Jump to content

parts needed for 1990 - 2005 Suzuki LT160


Recommended Posts

Hi all you guys out there.

I have a 1998 Suzuki LT160 Quadrunner.

I need 1 10 X 24 lug nut stud

I need 1 used "hub cap holder" The cap holder goes on below the wheel hub nut.

I need 1 used "hub cap"

Let me know if you have something I need and how much you want.

USED not new.

Thank You,

Pumpkin472

Edited by Pumpkin472
acquired new information
Link to comment
Share on other sites

Hi Josh, you "dirt demon" you,

1 bolt I need is called something, but I don't know what, but on the outside the lug nut screws on to it.

The cap is maybe called a hub cap? The cap holder goes on below the wheel hub nut.

I need 2 bolts that go from a arm on the frame, through the top of the fender and into the bottom of the front rack. I have no idea of the size or threads it would be.

Thanks so much for your reply

Pumpkin472

Link to comment
Share on other sites

Here is a link to a parts fische, select your machine using the dropdowns in the box labeled "OEM parts lookup by model fit", once you are in the fische for your mache, you can select different sections of the machine and identify the parts you need. This site also has some of the better prices I have seen for parts online.

Babbitts Sports Center | Arctic Cat OEM Parts | Can-Am (Bombardier) OEM Parts | Honda OEM Parts | Kawasaki OEM Parts | Polaris OEM Parts | Sea-Doo OEM Parts | Ski-Doo OEM Parts | Suzuki OEM Parts | Yamaha OEM Parts

On the front wheel, you will find the cap as part #12 and the wheel stud that the lug nut screws onto as part #3. If you are looking for those parts for the rear wheel, they are #2 for the stud and # 10 for the cap, the studs are different from front to rear, but the caps are the same. If you look at the diagram labeled "carrier" in the dropdown, I think the bolt you are looking for is #4. I looked up the parts using the 1998 model year.

Link to comment
Share on other sites

  • 2 weeks later...

WOW! You really went out of your way to help me. Thank you so much. You are terrific!!!!!

I got everything but the hub cap. I don't want to have 1 shiny new hub cap, so I will try to find a used one. I had searched the internet for a rack and found nothing that looked like my "carrier". There isn't anything you can't find on the internet IF you know the name of it.

Link to comment
Share on other sites

  • 4 years later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Forum Topics

    • By huntindog
      I am in the process of puting it back together after replacing the DPS gearbox.
      The manual I have states that it will need to be flashed by a dealer. Is this still true?
      Also , I have a mystery bolt That I cannot remember where it goes. M6x 70 or so.  Hex head with a flat washer.I will try to attach a pic.
      Pic is no go for now....Cox issue I will try again later
      TIA
    • By Parham
      My starter seemed to be "dragging" for a few weeks.  I thought my battery was going bad.  Bought a new battery, charged it fully, and still no change.  Relay clicks and starter MIGHT, reluctantly, turn engine slowly one or two revolutions.  Somebody (Mech?) please point me in the right direction...what connections/wires have come loose?
    • By Flash_fella
      I had a sudden loss of spark in my 1988 Suzuki LT300E quadrunner and we tried a new plug but still no spark. Then we checked the boot and there was no issues with it. I then took off the coil as I was going to get a resistance reading with a multimeter however I cannot find anywhere what the readings should be. The coil is a Mitsubishi F6T 411. Any help would be appreciated. 
    • By Mhatayas
      What should I do about this , bad oil leak where the filter cover bolts on . Can I use some gasket maker 

    • By NZrider
      My king quad 700 runs rough when cold then won't start some times but not often when it's hot. And occasionally smoke's a lot when it's cold I'm guessing that's rings but I'm worried unless it's causing the other problems
       
       
       
      All help is appreciated thanks
×
×
  • Create New...