Quantcast
Jump to content

Search the Community

Showing results for tags ' needed'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Community Discussion
    • General ATV Discussion
    • General Talk - Anything Goes!
    • New Members Area!
    • Where To Ride Your ATV
    • ATV Picture and Video Sharing
    • ATV Racing & ATV Events
    • ATV & Off Road Modifications
    • ATV Tires and Rims
    • This vs. That ATV & Off Road Comparisons
    • ATV Trailers, Haulers, and Attachments
    • Hunting, Camping, & Outdoors Forum
    • ATV Laws, Legal Issues, and Policing
  • Regional ATV & Off Road Forums
    • Northeast ATV & Off Road Forum
    • Midwest ATV & Off Road Forum
    • South ATV & Off Road Forum
    • West ATV & Off Road Forum
    • Other Region ATV & Off Road Forum
  • ATV Manufacturer Specific
    • ATV Forums By Brand
  • UTV Side x Side Manufacturer Specific
    • UTV & Side by Side Forums By Brand
  • Other Powersports, Offroad, and All Terrain Vehicles
    • Kids ATVs and Youth Off-Road
    • ATC 3-Wheeler Forum
    • Dirt Bike Forum
    • 4X4 Trucks and Jeeps
    • Water, Snow & Other Powersports
  • QUADCRAZY Classifieds
    • ATV For Sale? Post it here.
    • Stolen ATVs
  • QUADCRAZY Supporters
    • ATV Links & Partners
  • ATV News, Magazine Articles, Product Reviews
    • ATV News, Articles & Press Releases
    • New ATV Products, Reviews & Tests
    • Manufacturer & Aftermarket Promos
  • QUADCRAZY Announcements & Support
    • Announcements/Support
    • Website How To & Feedback
  • Yamaha Grizzly Owners's Topics
  • New York ATV Riders's Group Forum
  • Michigan ATV Club - St Helen, Mio, West Branch, Rose City's Lets ride Michigan trails this season!
  • Michigan ATV Club - St Helen, Mio, West Branch, Rose City's Up coming season
  • Kawasaki Bayou 220 Restoration and Repairs's Topics
  • Ride Red's Videos
  • Ride Red's Ride Red Forum
  • NYC 2 Poconos/ Scotrun ATV Riders's ATV Upgrades
  • NYC 2 Poconos/ Scotrun ATV Riders's Quads
  • Mechanics Club's Topics

Categories

  • ATV News and Articles
  • ATV New Products & Reviews
  • ATV Racing & Events
  • ATV Ride Reports

Calendars

  • Community Calendar
  • ATV Racing Events
  • ATV Poker Runs and Riding Events
  • ATV Swap Meets
  • Other ATV & Off Road Events

Categories

  • ATV Repair Manuals
    • Arctic Cat ATV
    • Can-Am BRP ATV
    • Cannondale ATV
    • CFMOTO ATV
    • Hisun ATV
    • Honda ATV
    • Kawasaki ATV
    • Kazuma ATV
    • Kymco ATV
    • Polaris ATV
    • Suzuki ATV
    • Textron Off Road ATV
    • Yamaha ATV
    • Other ATV
  • ATV Owner Manuals
    • Arctic Cat ATV
    • Can-Am BRP ATV
    • Cannondale ATV
    • CFMOTO ATV
    • Hisun ATV
    • Honda ATV
    • Kawasaki ATV
    • Kazuma ATV
    • Kymco ATV
    • Polaris ATV
    • Suzuki ATV
    • Textron Off Road ATV
    • Yamaha ATV
    • Other ATV
  • UTV Side by Side Repair Manuals
    • Arctic Cat UTV
    • Can-Am BRP UTV
    • Hisun UTV
    • Honda UTV
    • Joyner UTV
    • John Deer UTV
    • Kawasaki UTV
    • Polaris UTV
    • Textron Off Road UTV
    • Yamaha UTV
    • Other Brands UTV
  • UTV Side by Side Owner Manuals
    • Arctic Cat UTV
    • Textron Off Road UTV
    • Can-Am BRP UTV
    • Hisun UTV
    • Honda UTV
    • Joyner UTV
    • John Deer UTV
    • Kawasaki UTV
    • Polaris UTV
    • Yamaha UTV
    • Other Brands UTV
  • Other Files

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Location

miles from

About Me


My Garage

Found 35 results

  1. I hope this is right form is not point me the right place. I have just brought a 07 king quad 700. Its got 14 rims with 28 tires. Can't remember what brand right now. What I would like is a programmer and a clutch kit for it. I'm used to diesel trucks really new to the fuel injected quads. Let me know what my bike needs thanks.
  2. Hi everyone, I am an emergency physician and I'm writing a chapter on ATV injuries for a Wilderness Medicine textbook (here's the link to the previous edition if you're interested.) I am asking for your help for photographs for the chapter. Here's what I need: 1) Photos of different types of ATVs 2) Photos of these ATVs in action 3) Photos of these ATVs crashing 4) Photos of injuries that occurred as a result of these crashes. If you have copies of the x-rays or CT scans that were obtained due to these injuries, all the better. I do not stand to profit from these images whatsoever. I don't get paid to write the chapter, nor do I receive any royalties from the book sales. All I get is an electronic copy of the book. Thus, I can't offer you any type of remuneration for the photos, but if I use one of your pics I can email you a .pdf of the photo in the chapter once it is published. Also, I can credit you in the book, e.g. "Photo courtesy of John Doe." Needless to say, you'll have to consent to the photo and your likeness to be reproduced in the book-- no worries, no lawyers or fancy paperwork involved. You can email the photos directly to [email protected], or PM me if needed. Thanks so much in advance for your help! Todd
  3. Looking for a shifter for my Moto 4 350. The one to shift from Hi,low,reverse. I'm in Chilliwack bc Canada. Thanks!
  4. I am looking for the service manual LIT-11616-BT-25. I know where I can buy one. I am more interested in a shared electronic version, or just some parts of the electrical section. I have a no spark situation and am trying to trouble shoot myself.
  5. Hi all you guys out there. I have a 1998 Suzuki LT160 Quadrunner. I need 1 10 X 24 lug nut stud I need 1 used "hub cap holder" The cap holder goes on below the wheel hub nut. I need 1 used "hub cap" Let me know if you have something I need and how much you want. USED not new. Thank You, Pumpkin472
  6. I am in need do a manual for the Suzuki Quadrunner LT230. Thank You very much.
  7. Just bought a 99 Magnum 500. Needs quite a bit of work. Seems like every other manual is on the site, but can't find one for a 99 Magnum. Any help would be appreciated. Thanks The http://www.powersportresource.com/ used to have it, but the link is dead now.
  8. Guys, I took my quad out for the first real run since I bought it for my kids, and the temp light came on and coolant was releasing out of the over flow bottle/tank. As I would speed up, I could get the light to go away, but as soon as I slow down, it comes back on. Heres the deal: The fan doesnt turn on until the temp light just about comes on or is on Here are the things ive done or checked: 1) Radiator fins are clear of debris/mud 2) Thermostat replaced 3) Head gasket replaced 4) New thermo switch 5) Radiator "burped" of air Anyone have any thoughts? Would a radiator cap at 15lbs instead of 13lbs cause an issue?
  9. Hi All Completely new to Quads but been a biker for over 35 years. Bought this quad for grandchildren, It runs fine, at the moment has a Loncin 90 (86cc) engine but no other identifying marks to give me a clue as to model which will make getting parts difficult. Any help with ID would be gratefully appreciated. Cheers Joe
  10. New memeber here..like most came looking for some help..other forums i have tried have not gotten any responses..so here goes 2001 wolverine..when problems started i went for a ride and 10 minutes into it, bike shut off..i could use push button and fire it back up..few mintues later shut off again this time i had to pull start it..drove it home and parked it..from then on i could not use push button or pull start.when i pushed start button no clicks or anyting, neutral light and oil light came on but that's it..so i inspected kill switch..it was bad..so i rewired to bypass kill switch (i think i got it right)..after this when i pushed start button i got a single click at the start circuit cut off relay (little white relay beside starter solenoid)..still could not pull start nor could i jump accross the solenoid to start (wasn't getting spark either way..so i replaced ignition coil (spark plug is new, i tried old plug as well)..still no changes..then i took off the start circuit cut off relay, using two jumper wires i completed that circuit with the relay out..kinda by accident i had unplugged the small red wire coming off the battery/fuse, at the bullet connector..now with the red wire disconnected, and kill switch bypassed, i could get it to crank at push button, but still no spark..but got it to start with pull cord..rode for 5 min, then it backfired, and the bike cut off on me, then it would start back up on its own (i guess because i was rolling pretty good).go for 10 yards, cut off, start back up on its own, 10 more yards cut off again.(by this time my speed was way down)...this time it just died and didn't start back up..let it sit a couple of minutes and finally got it to start with pull start..got it back home...after it cools down i can pull start it every time as long as that little red wire is disconnected, but it won't run for long, ( it will idle forever, but when i drive it and put a load on it, it will not run very long and it will cut off again..when i hook the red wire back up to use push button, i get no spark, but with that relay bypassed it will turn the starter, but no spark...i had inspected/cleaned all connectors, inspected all wiring i could( i pulled all tape off wiring harness and went over it)..i have been at this for a couple of weeks and am stumped at this point..i am gonna test my pick up coil later today ( i think i already tested it but i'm gonna test it again to be sure) and see if it is within spec..but i looked at the previous owners service records and in January of 2012 (one year and 9 months ago) he had the stator replaced at the dealer..so i'm thinking my stator is probably good, as well as the pick up coil, but you never know.. but i just don't know what else it could be..if my cdi was going bad, would i be able to pull start it and drive at all??.i read that when they go bad, they usually completely die. .disconnecting that red wire is the only way i can pull start it, hook red wire back up, and i get no spark either way (button or pull start) can anyone give me some advice/guidance on what to check next??..i'm starting to believe it is a wiring issue, but i have looked and looked and cannot find any bad/loose connections or bare wire/wires, not to say i haven't overlooked something..someone told me it could be the voltage regulator/rectifier but i dont think that's it..i'm leaning towards stator/pick up coil. in summary--- battery is at 13v when i charge it, then it will go down to 12.4 or so after i try turning the engine over..haven't tested under load..replacement battery is on the way in any case spark plug is new (also tried old plug which was still good) replaced ignition coil start circuit relay is bad, will replace asap, but can get starter to turn with relay bypassed with jumper wires and red wire coming off battery disconnected can pull start with red wire disconnected, relay bypassed, but will not run long, as soon as it gets warm it will start shutting off..will idle fine..just when i put the engine under load is it shutting off) also when i pull start, the neutral light is very faint (becuase red wire is disconnected)..but when i rev the engine, light gets even fainter headlights also flicker/dim when i rev it up (again with red wire disconnected) i believe i have kill switch bypassed properly..can't remember what wires connected, think it was a black/yellow stripe and red/white stripe) I also have my parking brake safety/rev limiter out of the circuit..( i unplugged them then plugged the black wire into back/white wire at bullet connectors and disconnected the white plug coming off the parking brake if i rememeber correctly) The only grounds i can find is the one coming off negative battery terminal, cleaned it, and the gound (black wire i believe) going onto the ignition coil, along with the orange wire..that ground appears to be good and is nice and tight I pulled wiring harness and inspected every inch, found no issues Any ideas, questions, concerns, or comments?? I have a multi meter so i can perform tests on wiring/electrical components..i also have an ammeter if needed..i just need some help on this
  11. I'm looking to get another quad. I found about 3 Ploaris quads I'm looking at. On some of the reviwes I watched on you tube and read. Some people love'em & some hate'em. The biggest statement is it's a hit or mis with Polaris. Heres what I'm looking at 2 2011 Sportsman 550's w/eps & an 06 or 08 outlaw 525 irs sport quad. I rather hear from people who own or have owned a Polaris to hear your thoughts on quality and what to watchout for. The review that was pretty bad was a 2012 550 the eps quit two times and started working and has been ok. Then the active descent control quit on both quads they were doing a long term test. I'm on the fence about looking at the Polairs quads. Please help.
  12. I work for a large distributor of ATV/Off-Road Helmets and we need your opinions on our next helmet graphic. Below are 4 surveys that will only take a minute each to fill out and you would be helping us to create a great looking helmet. This is not spam or an advertisement. Your opinions are greatly appreciated and very much needed. Thank you! Youth MX Helmet Survey - Youth MX Helmet SurveyYouth MX Helmet Survey Neutral vs. Color Graphics Survey - Neutral vs. Color Graphics SurveyNeutral vs. Color Graphics Survey MX Helmet Market Survey - MX Helmet Market SurveyMX Helmet Market Survey Adult MX Helmet Survey - Adult MX Helmet SurveyAdult MX Helmet Survey
  13. Dear guys, I just have a problem as my CDI box and its connector was taken off my bike (KFX700). I already got a Procomm replacement unit but as I do not have original connector I cannot connect it. Could somebody post pinout of CDI or a picture of connector where wires color and position can be seen clearly? KFX700 2005 Thank you for your help
  14. I have a klf 400 can someone help please i need a picture to show how all the timing marks and where they go its driving me mad please please help.: :mad:
  15. 1995 Bayou 220. If i have ruled out the ignition coil where should i go from there?
  16. I need an engine for a 2005 ltz400. My engine case has a leak and I'm afraid the damage may be deeper so To save money I need a compatible engine. I have searched Craigslist and had no luck. I won't downgrade but if it will fit on the frame I wouldnt mind upgrading. Any help would be much appreciated. Even if all that's done is a point in the direction of one.
  17. Hi I don’t know much about quads this is my first one have a 2006 Suzuki ltz400 when I got it they told me that is has a 440 bore kit and a hot cam, but the throttle has to pushed and pumped to get it started, so I cleaned the carb and it is running good now but the throttle still has to be pushed and pumped to get it started the choke axe like it does not work and it bogs down in reverse. Does anyone have any advice?
  18. Looking for any quad rider groups that are interested in being a part of a Monster Truck show at the New York State Fair in Syracuse on Sunday September 2 2012. Basically it involves 2 teams of quad racers competing at scheduled times during the monster truck show.
  19. I bought a semi-running 96 king quad 300, it had multiple fuel issues. It's beat up, dirty, and old, but that doesn't matter since it's only going to be dragging dead snowmobiles from trailers to my shop to repair them and put up trail signs for the club. When I bought it, it would run for about 15 or 20 seconds then quit, no matter what was done to keep it alive. A quick look at the guy's house showed that the choke had come off of the carb, all the vacuum and breather lines were off of it, and the original mechanical fuel pump had been replaced with an electric one that was activated by a switch so you had to turn it on and off. At home, I discovered that the cob job wiring for the fuel pump was not connecting to the battery any longer, and the switch wasn't actually turning the pump on. Reconnecting the wire to the harness, it would now run and stay running, albeit poorly because of the choke and vacuum lines being off. Go buy the parts, lube up the frozen choke cable, install the choke, and give the carb a quick cleaning. Guess where all the hoses go, since they weren't connected and I cannot find a manual for it. Ok at this point I figure I can make educated guesses since I know the difference between the vacuum ports and bowl vents. (i've been wrenching on stuff since I was a kid, but never owned a quad) Try several different combination, some will rev through all ranges but quickly flood the engine at low rpm, others will give it a good idle but have a horrendous bog getting out of the low RPM range. I found a 99 manual, but it doesn't give hose routing. It said the turn the air jet 2 5/8 turns out, and i found that the carb is at 5 turns out. Turn that in to the spec, and it now runs like total crap. Oh, and along the way I found that the petcock is leaking so that hose is now attached to the bowl vent. I grabbed a fuel pump from my sled, and hooked that up to replace the electric one that was butchered on there, and used the small white vacuum port from the carb as a pulse line. That works just fine I have plenty of fuel. It seems to run best with the other vacuum line wide open. Thoughts? Does someone know of a place I can download a manual or have a hose routing diagram they can upload and correct carb specs for the year? Thanks,
  20. I have a 87 LT250R (basket case motor)that I am looking to get rebuilt.I live in Upstate New York and am looking for someone who has good knowledge of LT250R motors and working on them.If anyone has any info please let me know.Thanks
  21. I need a CDI box for an A/C, 02,300 4X4.
  22. I need help with the torque specs on the swing arm pivot pins for a 99 yamaha bear tracker. Thanks!
  23. I bought this 98 Suzuki knowing that the front differential was bad, and the rear one might be. But I am on Social Security without much money, I am disabled, can't hardly walk, and the only way I can keep on hunting and fishing is if I get this running; this is what I can afford. I followed the instructions in my Clymer repair manual; so far everything is dismantled and the right front axle is out; it came out just like the book said it would with a "light tap". But I can't get the left front axle out no matter what I do. It is supposed to come out as easy as the right one, with just a light tap or two; but I have tapped and banged as hard as I dare to without breaking something; I just cant get that left front axle out; what am I doing wrong? Is there some kind of circlip, or retainer, on the left axle inside the differential that holds it in? I cannot find anything in the Clymer manual that says there is; but that axle just will not budge; and as I said a little tap isnt doing it; and I am afraid to bang on it any harder. I can't affor to take it to a shop; not only that but the front end is all apart and I couldnt get it into my pickup bed even if I wanted to now. So will somebody please help me and tell me what I am doing wrong; I really need to get this running so I can keep on fishing and hunting. Thanks Ken
  24. Does anyone know of a repair manuel that covers the 2005 Suzuki Eiger LT-A400F?
  25. Hi, I bought my Warrior used, but the headlight(s) was gone (wiring is there). What is a cheap alternative from OEM for headlights? I assume I'll need some sort of mount too. Thanks.

×
×
  • Create New...