Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

ATV & Off Road Modifications

Share your ATV & Off Road modifications and projects. Get help with your ATV mods by posting what you are working on, your progress, and how your final project is coming along. Show is your modded ATV, UTV, Side by Side, ATC, or other Off Road vehicle.

189 topics in this forum

  1. Post your mods... 1 2 3 4 5

    • 123 replies
    • 30,292 views
    • 1 reply
    • 9,392 views
    • 4 replies
    • 234 views
    • 0 replies
    • 117 views
    • 3 replies
    • 469 views
    • 0 replies
    • 176 views
    • 1 reply
    • 449 views
    • 1 reply
    • 595 views
    • 1 reply
    • 1,138 views
    • 1 reply
    • 326 views
    • 1 reply
    • 259 views
    • 0 replies
    • 239 views
    • 0 replies
    • 184 views
    • 5 replies
    • 380 views
  2. YFZ hybrid

    • 1 reply
    • 399 views
    • 37 replies
    • 15,134 views
  3. Where to Connect LED Light Bar?

    • 3 replies
    • 789 views
  4. Lift kit issue

    • 0 replies
    • 301 views
  5. 6 lt250r

    • 2 replies
    • 244 views
  6. Grizzly Build

    • 5 replies
    • 764 views
    • 3 replies
    • 1,285 views
  7. Mods for a 220 Bayou?

    • 2 replies
    • 465 views
    • 3 replies
    • 687 views
    • 1 reply
    • 538 views
    • 5 replies
    • 1,313 views
  8. Axle guards

    • 5 replies
    • 613 views
    • 1 reply
    • 463 views
  9. Guru bumpers

    • 2 replies
    • 677 views
    • 2 replies
    • 1,335 views
  10. Purchased SunF Mud Tires

    • 0 replies
    • 1,125 views
  11. SunF Mud Tires & clutching

    • 0 replies
    • 748 views
  12. atv tool holder

    • 1 reply
    • 1,272 views
  13. ATV Tires

    • 4 replies
    • 1,960 views
  14. Made myself a new bumper.

    • 11 replies
    • 3,403 views
  15. 1994 King Quad with tracks?

    • 0 replies
    • 1,108 views
  16. custom graphic kits

    • 24 replies
    • 18,127 views
    • 2 replies
    • 2,378 views
  17. pc3 map

    • 0 replies
    • 1,027 views
    • 1 reply
    • 1,409 views
  18. mods needed for a king quad 700

    • 1 reply
    • 1,215 views
  19. 89 Yamaha Big Bear 350 4x4

    • 10 replies
    • 21,456 views
    • 0 replies
    • 1,309 views
  20. apache f100 help with tuning

    • 1 reply
    • 1,754 views
    • 2 replies
    • 3,633 views
    • 2 replies
    • 1,289 views
  21. Seat Covers

    • 1 reply
    • 1,288 views
  22. DIY Skid Plate

    • 5 replies
    • 2,519 views
  23. Engine for tractor pulling

    • 10 replies
    • 2,636 views
    • 2 replies
    • 3,370 views
  24. Latest Mods to My Can-Am

    • 2 replies
    • 5,201 views


  • Latest Forum Posts

    • Guys, had a worn smokey recon 250 to the point it it was fouling plugs. Well pulled the jug looked great and believe my culprit was valve seals. They could not even hold the valve in place. So honed the cylinder for good measure and installed new rings while it was apart. Also lapped valves while it was apart due to little corrosion on the intake valve face, went on and did exhuast while it was apart also. Reinstalled everything, adjusted valves, I cant remember how far out they was but they where out a bit. Well long story short it started up, ran great for about 20 minutes and then randomly died while accelerating. Compression is 60 psi at best.... double checked valve lash and it was way out?? Adjusted it, but you can tell its not right. Still no start, and with rockers arms removed still not compression......? Which making believe ring issue? But why is valve lash  all over the place?! Is there an easy way to check cam to crank timing to make sure it hasn't jump time? Thanks!
    • Have you checked the gap on the pick up coil? I remember a post way back about a similar problem and it turns out the gap on the pick up coil was the problem.   It ran great in place but after a load was put on it the atv it bogged down.  
    • I bought a new carb thinking it was the problem, wasn't. But I kept the original carb, and it looked great inside, so I just put the original carb back on. Whole electrical system has been replaced. I am just baffled. It seems like a fuel problem. But I can't seem to figure it out. 
    • Is there a website for the uk pal as this ones coming up in euros
    • cheap replacement and it ran just like the original oem   

×
×
  • Create New...