Quantcast
Jump to content


2005 arctic cat 400 automatic


Recommended Posts

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Forum Topics

    • By Gwbarm
      I generally use Non Ethynol fuel in all my small engines. I just got back from the gas station and that fuel has really increased in price since last year, I will continue to use it, even though its north of 1.00 a gallon more. That seems minor compared to cleaning and repairing carbs every year. 
      I was just curious as to what others are doing in regard to gas in their quads, i know a lot of the newer ones are fuel injected which shouldnt pose a problem, but i have had lots of problems with rust and jell forming in carbs when using ethynol fuel.
    • By Gwbarm
      I Ran across this video today comparing an aftermarket to OEM Carb on Suzuki Vinson, thought it might generate some interest, it is quite long but informative.
       
    • By semicolon
      Hi, I am having issues with my TRX350D fuel pump.  It suddenly stopped running so I have replaced all the fuses and cleaned all the terminals.  I have fitted a new pump, fuel cut-off relay and rectifier.  Still nothing!!  The pump runs when attached to a battery.  The engine will start on the choke and the filter fills with fuel but it will  not rev and dies when the choke is closed. I have power to the relay but nothing at the pump black/white wire when cranking the engine.  Any ideas where to go from here would be very much appreciated!!
       
    • By bighoss
      i got my son new outlaw 50 a few weeks ago and we went rideing yesterday and while we were riding it died and it took me like 10 min to get started back and it died agen when we got close to truck so i pulled it back took the plug out it looked like it was drop in a bucket of gas took the air filter out and the ait box was full of gas also got home it started rite up today i started it it starter up but was blowing what look like water out of the exholst let it idel for a lil bit did not die but as soon as hit the gas and let off it will die what does that sound like i thnk i going to take it back to dealer and tell them to fix it as it is under warrenty but would like to know what it could be first
    • By ResQ91
      Hi Guys!

      New member and could really use your advice. I would have to believe this has been an issue for others but a search here came up with nothing......? (Probably me not doing search correctly)
       
      I have an 87 Big Bear 350 YFM350FWT
      The OEM Mikuni BTM carb is shot and would rather replace than rebuild.
      It is no longer made and I have had good luck with NICHE carbs so I ordered a #K-CRB-0006 This was what they said was replacement when ordered. This Carb only uses 1 Throttle cable. The Slide is linked so it uses one. (OEM had 2nd cable coming through top to move slide)
       
      Problem is when I ordered a replacement Cable from NICHE (#C-CBL-0061) the Cable wire is a little short, not allowing Throttle to return all the way down to Idle position. I called NICHE and they are at a loss. Haven't gotten back to me after 2+ weeks.
       
      What would you recommend other than a carb rebuild?
      Can I just use 1 of the OEM cables (It is the right length) and snip/disconnect the other that went to top of Carb for Slide?
      Or ??
       
      Thanks in advance for any advice you have!!
       
      Dave
×
×
  • Create New...