Quantcast
Jump to content

  • Do you own an ATV or UTV? Join our Forum!

    Join QUADCRAZY ATV Forum today for FREE! We keep these forums clean and user friendly. All first posters will have to wait to have their content reviewed and approved. Once your first post is approved, you will no longer need to got through an approval process. To gain immediate approval and a NO ADS experience, consider subsribing to our Premium Membership.

2004 Suzuki LTZ cooling fan wont come on


atvgirl1975
 Share

Recommended Posts

I just bought a used 04 LTZ. I have been riding it without incident for the last few months and then i was riding it kinda hard up some switchbacks in the mountains and the temp light came on. I stopped, put my quad in neutral and the fan never came on. I have heard it come on in the past. Any ideas?

Thanks,

Amy

Link to comment
Share on other sites

without putting a multimeter on it its really impossible to say what the issue is. I cant get the fan to come on with my TRX. It will come on if I jump the sensor to a ground though. Leavign for the dunes in 3 days I just made a quick jumer from the temp sensor wire to ground so the fan runs all the time. It will take longer for it to warm up I guess but thats better then the oposite. I'll pull the sensor after vacation and test it.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...