Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

JohnP3

1989 Suzuki LT250 4WD Too Much Fuel

Recommended Posts

I am a retired HD mechanic, I bought a Quad, it over fuels, I have set the Float it has the 31 mm carb so there are no external adjustments, The vent line from the fuel bowel, where does it go to or does it just hang down. The vent line for the fuel pump, is OK. I re torqued the head and set the valves.

I have checked the ignition all tested good.

Feels like the choke is always on , but the brass piston with the needle on the end seems to be sliding free.

I bought a manual It is close to useless, it only shows the 29 mm carb, and does not show the hose routing, or I do not know where to look.

I understand carburetors on Vehicles, this one is totally new to me?

Share this post


Link to post
Share on other sites


The carb breakdown link you gave me is not what I have when I went to pit stop.com it has a picture of the carb I have and it calls the hose a vent, But it shows a "T" and does not show were the other hose is or where it goes.

Share this post


Link to post
Share on other sites

It has the 31 carb on it and was told the slide if worn would cause a problem Bought a new slide diaphram assembly, new float and set it to 13mm, new pin and tube the pin goes in that the jet screws into. It will kick but not run.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Dra O
      posted a while back - it was running at one point - I have all the plastic shroud off - it's down to frame and engine now
      -fuel pump: when line from petcock is attached, no fuel comes out other side to carb; the line to the carb is open (can blow through it); I thought when I cranked engine that the pump would spit out fuel on other side but it does not; I removed fuel pump and opened it up - diaphragm looks good - but internal areas had lotsa calcification build up - I cleaned this out and dried it good - the clear plastic pieces (?diaphragms) aren't broken - the spring w/ steel ball on end moves freely; am putting it back on tomorrow; but can anyone answer about the pump? isn't it supposed to pump fuel through it... to other side... to carb? puzzling
      -along with fuel pump: I replaced petcock 3 weeks ago (gas tank had rusty fuel in bottom - cleaned it out prior to new petcock); when I turn petcock arrow NOT to on or reserve, fuel comes out of line; when I turn it to on or reserve, fuel doesn't come out; puzzling
      -I don't know what's on back of fuel pump - it's a valve that has a hose coming out of it - looks like it goes to engine/carb - I haven't traced this out yet - what is it?
      -can squirt gas on air filter and engine will run for 2-3 seconds then stop - fuel in top of carb (under diaphragm) does same
      -it likely needs carb rebuild - will get to this - but something isn't allowing fuel to get from fuel pump to carb
      -I THINK it has a mikuni model x carb - diaphragm is ID 26mm  OD 68mm - hard to find inexpensive diaphragm, I guess because it's a model x
      -last thing - I replaced solenoid due to old one clicking; I HAVE to be charging the battery or it won't start/turn over - battery just goes dead; but if charging, it'll turn over nicely; i'm guessing it's a bad battery
      -any help appreciated - I've never owned an ATV before - inherited this beast from grandparent in-law
    • By Ed Zeppeli
      Hi,
      Oddly I'm having  a hard time ordering front brake shoes for my '98. 
      I'd appreciate recommendations on decent, widely available shoes if possible. Ideally available in Canada on short notice.
       
      Thanks much,
       
      Warren
    • By Rich1028
      Leota Quad Trails  on New to us  Machines 5-10-20
      We Just Picked up two Quads Friday,and we took them out riding,great machines!
      2008 Honda 400 Ex and a 2014 Honda 400 X

       
       
    • By hornythrony
      Hey I have a 07 king 700 there's lots of times that the quad will stall when the fan turns on also have to bump motor 2 or 3 times before starting to start it (makes fuel pump go on 2/3 times) anyone having or had this issue?
  • Similar Tagged Content

    • By Guythis448
      Looking for help on wiring up stock wiring harness specifically for a '88 Honda TRX 300 
      If anyone could drop a link or send me a PM it would be much appreciated 
    • By Jers
      I need to know what I have and what tire really go on it, Mine has 24x11x10 on the back and 22x8x10 on the front and I need new tire but I don't think are the right size. Also I can't find the model number listed but it looks like a 250 quadrunner 2wd and I think it is a 1987 maybe, can anyone help me, also I it has a rich running sound and I put a carb diap in it and cleaned the carb. is there a jet needing replaced?
    • By Steve1266
      I went out to ride my quad today. When I started it up it ran for a minute, then died. Since then it will turn over but won't start. I've check the spark plug and get great fire. I have had this quad for about 6 months, and very new to breaking it down. But need help. Thanks
    • By suthernboy60
      Since I am not much of a mechanic simple things confuse me. How do you remove the old brake cable for the pedal brake from the frame? Thought I could just pry it out but no luck and not much room to work. Any help is appreciated.
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...