Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

sunpup

Polaris700 (2004) Sportsman Electrically Dead

Recommended Posts

Everything suddenly shut down on the trail--no ignition, lights, nothing. It wasn't the battery; we hot wired it to get it home.

Is there a circuit breaker or fused link somewhere on the vehicle--I don't see it.

If the vehicle shut down like this, can I assume that I have a serious short somewhere?

No dealer to ask--and Polaris is the worst company to try to get any help or answers out of--they simply refuse to communicate by phone or email.

Thanks!

Share this post


Link to post
Share on other sites


I think you have a break somewhere or open (short). You have to try to get your hands on a wiring diagram from the dealer or buy a manual to troubleshoot it. Start witht the main power to the fuses and relays. You also may have a faulty main relay....

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Forum Topics

    • By Arnold Schimberg
      Hi Guys
      I have 88 4trax FW , it has a booster circuit
      In the cdi control fed from a leg in the alternator. 
      MY Honda service manual says you will get no spark without this circuit on this model. 
      Can someone explain a little about this please ?    Thanks
    • By Rick Shropshire
      Happy New Year all! Remember not to operate any vehicles while under the influence, you could get busted or worse, you could get hurt or hurt someone else who's playing it safe and end up in jail. Have fun and be safe.
    • By JacobSlabach
      Got a 04 Sportsman 500 that wasnt running- owner said it needed a stater and a new battery.  It ran rough (been sitting out in the weather for a while).  A friend and I started by adding a new battery and it would start barely with the choke and his hand over the air-filter.  I decided to install the new battery in the holder on the side.  we had it on the rack because the old on was still in the bike.  I tried to be nifty by turning the battery to put the terminals in an easier spot to get to, but forgot to reverse the cables too.  In a sentence, I reversed the positive and negative on the battery like a dummy.  When we discovered my mistake and corrected it, we turned on the bike, but the display did not light up and the key did not turn on the starter.  jumping the solenoid worked the starter, so we thought the solenoid just burned up when I reversed the pos and neg...  new solenoid and no difference.  what have I burned up?  Also, the shifter does not seem to do anything in the trans.  it slides back and forth like its stripped in the trans.  any help would be appreciated!!
      I think the biggest issue right now is the electrical.
    • By Rich Arno
      Hello. I'm new so I hope I'm posting in the right place. My neighbor gave me a nice looking Bayou 220, but I can't get any fire to the plug. No lights, nothing. So far I've put in a brand new battery and relay. So those are good for sure. No neutral light comes on when the key is turned. Where should I start to try to figure out this electrical problem? I have a new coil to install, but common sense tells me it has to be something before that. I'm cheap so taking it to the dealer is out of the question. Does anyone know the process of elimination in a situation like this? I'd might add it LOOKS like the wires are all where they belong, but I can't say they are for sure. If the machine wasn't in such great shape, I wouldn't bother, but the grandkids should have a lot of fun on this. Thank you in advance for any help someone can offer.
    • By johncb
      The battery box on my machine kind of fell apart and I was wondering if this has happened to anyone else and what they did to rebuild the box.
    • By JamesD
      I am having what I think is ignition problems. My 1994 Bayou 300 seems to flood very easy when starting. At first I thought it was a carb problem but while testing the spart I noticed that there is no spark while the engine is turning over. When you let off of the ignition swith there is one spark. But only when you let off of the ignition switch. It has a new coil, plug wire, and plug. Any ideas? I dont know if it is the ignition box, or maybe the ignition switch. Any help would be appreciated
  • Similar Tagged Content

    • By LTZ-Zach
      So i was riding the other day and my quad randomly shut off. It started back up and ran completely fine for a little while and then it started idling terribly.
      I cleaned the carb and changed all the jets and everything except the float due to the rebuild kit not coming with one and it actually runs worse then it did before.
      It will run and idle decent now but when I give it gas it dies.
      Does anybody know what could be wrong?
      I also changed the spark plug and air filter along with the oil and oil filter.
       
    • By ut1w7b
      I have a 94 sportsman 400. It sat for several years before i got it. I have cleaned the carb it will start and run for about 5 min then it will flood. I have torn it down and cant see anything wrong. has anyone else ran into this problem any hel would be great.
    • By buzzar56
      I am looking for a free repair manual for a 2003 Polaris sportsman 500 ho atv. all the posts on here lead me noplace
      thanks fred.
    • By bodatiouskid
      Have a 2002 Polaris Sportsman 700 that only has 34mi. on a carb & ring job.
      Cut the gas off today to drain carb.Now engine will not idle.If I open throttle will run,but let off & will cut off.Can screw idle in with no change.
      What happened? Why did this happen when fuel ran out?
      Please help me,my ATV is a daily driver.
      Please help!!
  • Recently Browsing   0 members

    No registered users viewing this page.


×