Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Earthmover

problems RZR XP 900

Recommended Posts



Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Christian Brindle
      I have a 2000 Polaris Sportsman 500. A year or so ago we got it running after replacing the kill switch. It ran great but after some use for a couple months it got a flat tire and for some reason we just forgot about it and it sat for some time. Before it sat i replaced the gas cap, fuel filter, fuel pump, petcock, battery, starter relay, oil and oil filter. I recently went to start it and it started so quickly and without choke or throttle but the ATV wouldn't move till about 1/4 throttle and it wasn't really a smooth ride until 1/2 throttle. it also would bog out randomly after you came to a stop and sounded like it was getting too much fuel. I cleaned the carb and adjusted the air/fuel screw to 1 3/4 turns out.  I also messed with the idle and the throttle cable adjuster up on the handlebars. It's safe to say it now runs worse than when i started working on it 2 days ago. It takes more effort to get started and bogs out idling after about 30 seconds. I tried adjusting the idle but every time i do it'll get to a sweet spot but after driving it down the driveway and back the idle will go up and down to the point where i can't put it in gear because the gears will grind. Any thoughts or ideas would be greatly appreciated. Thanks
    • By Flipper Tiffany Roper Jones
      All I have been through everything. Bought brand new.
      Throttle safety switch 
      Cam and rockers
      ECM
      Carborator
      Stator
      Fuel safety switch 
      Battery
      Everything every forum has spoken of I've bought sealed airbox completely tight unplugged black wire on trans. I have literally done everything in the book.Checked oil today full of gas anyone no anything what might b wrong. Next I'm taking head off and making sure valves seat any ideas.
    • By Larry Fox
      Just bought this ATV. Wondering if my gauge from a 2003 will plug in and work. I know mine does not have a fuel gauge, but if the rest works, I am in. 
    • By Larry Fox
      Looking for the wiring diagram of the gauge cluster. Thinking about using it on my 2008 that I just bought.. Its gauge is destroyed
    • By Travis Johnson
      My 1988 Honda 300 fourtrax has a short all of sudden neutral light works but when I put on headlight nothing can't start it unless kick start please help
  • Similar Tagged Content

    • By Kingquad1
      Hello I am new hear. I just purchased a 1998 Big Bear. It was sitting for 3yrs in storage. The guy I bought it from got the carb cleaned and it runs good. I am having problems with the neutral light. When I shift into neutral the light does not come on. If I mess with the gear shifter, I can get it to come on so I can start it. I can still pull the hand brake and start it that way. I cant find the neutral safity switch on this machine. Any suggestions would be great.
    • By atvinca
      I just picked up a really clean 1995 Moto 4 350. It runs great, but it will only go into one forward gear, neutral and reverse. I can run the shifter up and down and it will finally find a gear, or neutral. What should I do to trouble shoot this?
      Does anyone have a service/repair manual for this model?
      Thanks!
    • By allonroad
      2015 Polaris RZR XP 1000 EPS High Lifter Edition, There aren't many used Highlifters available on the market. Here is a chance to save $$$$$ on a very nice, well cared for.... For more information and photos contact me at [email protected]








    • By allonroad
      2015 Polaris RZR XP 1000 EPS High Lifter Edition, There aren't many used Highlifters available on the market. Here is a chance to save $$$$$ on a very nice, well cared for.... For more information and photos contact me at [email protected]








    • By bayouman
      I have a 1992 Kawasaki bayou 300 4x4. My initial problem it would not run unless full choke was on. So I tried cleaning carb and installed a rebuild kit and it ran bit better but not much. So I replaced carb and spark plug and regulator/rectifier. During testing of new carb the rectifier burned up so I replaced it. Now it fires up and idles fine but it backfires when you rev it up and then it will die as if the key was turned off. Now I know that the coil, cdi box, and stator are all connected. But I don't want to replace any unnecessary parts . This seems to be a ignition/electrical problem. I could really use some advice here as how to go about this. Thanks.
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...