Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

nkitchy

'08 Polaris Sportsman 500 x2 EFI - back firing and stalling out

Recommended Posts

I am in need of some help. I have a 2008 Polaris Touring Sportsman 500 efi. It only has about 540 miles on it. It's been back firing and stalling out lately, but will start right back up w/ no problem. We changed the air filter and pre filter, changed spark plug, drained all the gas and added newer gas, and changed the oil while we were at it. It was still doing the same thing. Took it to the Polaris shop and it had no codes showing up and when hooked to the computer it said all was good. I explained to the guy that it was back firing and stalling out once you been riding it for a little bit. He took it out and it did the same thing to him. It would also die out after being left in idle for a few minutes.. They found a spring fell off that had to do with the throttle and they fixed that and adjusted the throttle. Tested it and said all was well. Had it home for a few days and took it out today and ... same thing. It backfired, wasnt a loud backfire but still was spitting and backfiring. and when i slowed down for a turn, it died out on me. Again, it starts right back up. Does anyone have any idea what is going on? Or heard of this? i dont really want to take it back to the Polaris shop and be charged and arm and a leg. PLEASE PLEASE help!!!

Thank you for your time!

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Eddie Rahm
      whats up fellas....the white wire going from the throttle body came unplugged from the circuit  board and im not sure where it plugs back in to ? i see where the red wire goes but im not sure where the white wire goes...im not even sure what those wires do..any help would be appreciated..thanks. 1996 polaris sportsman 500 4x4 push button awd.
    • By Christian Brindle
      I have a 2000 Polaris Sportsman 500. A year or so ago we got it running after replacing the kill switch. It ran great but after some use for a couple months it got a flat tire and for some reason we just forgot about it and it sat for some time. Before it sat i replaced the gas cap, fuel filter, fuel pump, petcock, battery, starter relay, oil and oil filter. I recently went to start it and it started so quickly and without choke or throttle but the ATV wouldn't move till about 1/4 throttle and it wasn't really a smooth ride until 1/2 throttle. it also would bog out randomly after you came to a stop and sounded like it was getting too much fuel. I cleaned the carb and adjusted the air/fuel screw to 1 3/4 turns out.  I also messed with the idle and the throttle cable adjuster up on the handlebars. It's safe to say it now runs worse than when i started working on it 2 days ago. It takes more effort to get started and bogs out idling after about 30 seconds. I tried adjusting the idle but every time i do it'll get to a sweet spot but after driving it down the driveway and back the idle will go up and down to the point where i can't put it in gear because the gears will grind. Any thoughts or ideas would be greatly appreciated. Thanks
    • By StolenATV
      Went to church Sunday from 9:30am got home 2pm to find my 2 seater side by side stolen
      The post Stolen 2019 RZR S 1000 Polaris appeared first on STOLEN 911.
      View the full article
    • By Ted Aregi
      I've got a king quad 750cc has anyone converted the fuel pump relay to a stronger fuel pump relay on there king quad?
    • By Brandon Bollinger
      Doesnt seem to make the sound all the time. Mostly does it under load or going up an incline. Its kind of like a clunk and or grinding noise, Kind of hard to decipher. Today while going up an incline it actually stopped and it sounds like something spinning and then it ingauged again and it would move. I checked the clutches and installed a new belt before it did that also. Rear drive shaft seems ok where U joint is too. Has all new rear CV shafts and bearings and al new bushings in rear arms. Also flushed out the rear Diff with no shavings. Any ideas or where to check. 
  • Similar Tagged Content

    • By Alois Specht
      Hi there , have a KAZUMA 500 JAGUAR the rear diff is permanently locked , how can I get it out of lock just about tried everything I think, ?? .  Thank you your help is appreciated.
       
    • By mrfartsalot
      i have a 2001 suzuki quadmaster 500 4x4 that the primary cvt clutch is rusted on any ideas on how to get it off i want to try to reuse it if possible.
    • By Paul Maple
      I have a 1999 Sportsman  500, it was running fine, than started to lose power in the winter, I adjusted the idle screw and away I went, than a few weeks ago it died, I have found that i am flooding the engine, compression was at 70PSI and due to the compression release mech. i assume i am good as it compared to the same PSI on a 2000 sportsman 500 i have. i cannot start the atv unless i go full throttle and it starts an runs for about 30 sec than dies, again it is flooded. i ordered a new carb off ebay as i could get one for around $40. put that in same issue, i have checked the timing, (good), valves out of adjustment i adjusted to .006 still same issue, i have found the exhaust lobe and rocker arm to have some wear, i have ordered new ones, but am looking for any other input in this area as well. would the exhaust cam and rocker arm cause the engine to flood? i have used a bore scope and the piston liner has good cross hatching still? any input would be great.
    • By colin james
      View File 1996-2000 Polaris Sportsman 335/500 Service Manual
      This is the factory service manual for the polaris sportsman 335 & 500.
      You can download the section you need  or download all of the chapters for the complete manual 
      Submitter colin james Submitted 10/19/2018 Category Polaris ATV  
    • By colin james
      This is the factory service manual for the polaris sportsman 335 & 500.
      You can download the section you need  or download all of the chapters for the complete manual 
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...