Quantcast
Jump to content

  • Do you own an ATV, UTV or SxS? Join our Community Forum!

    QUADCRAZY ATV Community and Forum are FREE to join! We keep our ATV, UTV, and SxS forums clean and user friendly. All first time posters in our forums will have to wait to have their content reviewed and approved. Once your first ten posts are approved, you will no longer need to go through a forum post approval process. To bypass the approval process with immediate access and a NO ADS experience in our ATV, SxS, and UTV forums, consider subsribing to a Premium Membership

2000 Suzuki King Quad 300 4x4 - Not Cranking ??


mattrankin

Recommended Posts

i have a 2000 suzuki king quad 300 4x4 and i washed the air filter one day with gas and let the air filter dry and put it on and it wouldnt crank? it has spark and if you put your hand over the carb it aint getting suction but i pulled a skinny black hose going to the carb (either fuel or vacuum?) and it was blowing air out of the hose and sucking where it goes onto the carb. i would like some suggestions please

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...