Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

CaliforniaHG

Not a quad, but Ferrari Air Boxes

Recommended Posts

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Tagged Content

  • Similar Topics

    • By Hunter19
      How are you doing guys I just joined I have a 1998 Suzuki King quad I’m having problems with high RPMs the ATV idols perfectly but soon as a throttle up it doesn’t stall but it just bogs down it has no power any suggestions thanks
    • By Carl Edouard Denis
      Hello to al, ,
      First time poster long time ATV rider. I just go a used 2003 TRX650 got the card cleaned and it started up right away. ONly problem I am having is that its idling high. Any ideas as to wy this may be happening?
       
      CED
    • By Bmac
      I have been working on a 2004 arctic cat 400 that will run for a while with a new coil installed then after a few min start sputtering and quit. Checking the coil afterward it it is burned up. There is 350 Plus volts going to the coil and I'm not sure if I need a CDI or its something else? Flywheel magnets have been ruled out!
    • By chuckufarlie
      I have a 2018 Kodiak 450 EPS that just this past Sunday I ran through a bit of water.
      After the puddle the belt was slipping, so I pulled over and drained the ultramatic housing and the slipping problem went away. This was all in L and everything seemed to work fine. Later when I got on a road, I put it in H, but it still rode like it was in low... i.e. I had to rev it up a lot just to get to 30mph.
      When at home I pulled the ultramatic cover off to inspect, and it looked okay in there. Not much dirt, belt and everything are clean, but when I rev up the engine (with cage in place, of course), the belt doesn't get to the top of the clutch (maxes out about an inch or 1.5" from top of clutch, so maybe it is normal).. I put it back together but same thing... H seems like L still.
      Do you think the clutch needs to be further dissected for cleaning, or could this be an issue with the gear selector?
       
    • By Nate Clark
      So I have a 2003 Polaris Predator 500 completely built and running.  And then I have a 2004 Polaris Predator 500 completely disassembled.  I've got the suspension, handle bars, steering and bottom of the motor on the brand new frame (previous frame was totaled, that's why it's disassembled).  Everything else is in boxes.
       
      I've done all sorts of repairs on quads, ATVs, dirtbikes, snowmobiles, boats, cars...was a mechanic by profession in the 80's and wrenching my entire life.  Done top end rebuilds on multiple bikes over the years.  But I've never put a box of parts together like this.
       
      It shouldn't be hard as I have a running bike to look at and I have the factory service manual as well as a print of the polaris parts manuals.  My question is in the best order to put this thing together.  I can't locate a set of instructions to follow.  I can figure it out without instructions but I find that instruction guides save me a lot of time.  I'd like to get this thing running by June and it will be an after work, weekends project.
       
      Any pointers on the order of assembly...where to start...would be highly appreciated.
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...