Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

spitfire

Sitting for 7 years - start up process

Recommended Posts

Just bought a 1995 300l 4x4 yesterday and it has been sitting for over 7 years. Have put a new battery in it but I am unsure other than draining the gas what to do before cranking it over. Was real lucky on this deal. I picked up the 300l and a 1999 Magnum 500. both for $450.00 Canadian. Both ran prior to leaving them sit and are were sold as no start parts quads.

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Hellraiser69
      Just got a new to me, 99 Kodiak w/ plow and an extra set of tires for dirt cheap. I'm curious where you guys purchase your parts for your older ATV's? Google is great to find parts, but I'm hoping you guys have some stores, online, that you prefer on a recommendation basis. I've already purchased my tune-up items, but the brakes need some work and I'll likely end up having to replace the steering stem bearing, front CV axles and a few other things down the road.
    • By bren7176
      So honed out the cylinder and got most of it nice nice but left with this .. Might just have to have the things bored out now ..... some before and after..pics.
      1995 Polaris Sportsman 400 4x4 
       
       

       
       
      have to have the things bored out now ..... some before and after..pics..









    • By bren7176
      What would be the compression on a 1995 Polaris sportsman 400 4x4  ?? Have one in great shape plastic is almost like new and the engine only has 90 psi which I figure is Capulet ...
       
      brendan 
    • By Sp33dy0000
      Hi can someone please give me some sort of idea I have a Yamaha 600 grizzly four-wheel-drive I have put a new coil and a new stater and Pulse stater on it with new plug and steel can’t get any fire
    • By John Dunn III
      Just bought a LT 230 anything I should watch for. It runs and drive good. Just don't want no surprises 
  • Similar Tagged Content

    • By Ironfist104
      My wolverine has a new carb kit, new battery cranks over and over take it to the point of killing the battery to start sometime.... but it I give a tug on the start rope while I'm cranking it with the starter it fires right up.... any advice?
    • By izzydum1
      Any ideas on what would make a coil not fire? She was running fine, then began slow start. Now wont start at all.
    • By Suzuki24
      I have an 04 ltz and it started sputtering a little bit while going down the road and I was low on gas so I just figured that's what it was. But now I can't get it to start I completely cleaned the carberator put a new spark plug and coil pack in it and all it does is turn over. It has compression it's getting fuel and it is sparking but all it does is turn over any idea what it is??
    • By jerrymcoo1
      If you keep the starter button down it will run alittle let off the starter and it dies ? HELP
    • By RichUncleSkeleton
      Hello
      Just signed up, as I've had a recurring problem, and need some help.
      To start the bike I have to put the choke on all the way and 4 squeezes on the gas, Then as I push the start, I slow squeeze the throttle about half way for it to catch....If I miss it, then it will take 5 mins of slowly finding the sweetspot on the choke in unison with some throttle squeezes.
      Then I have to to hold the throttle to keep the bike going, using the choke will stall it out. after about 3 mins of holding the throttle, I then can let it go, and it idles fine, and runs fine. If it sits for a few hours it's only slightly hard to start, but a few days of sitting, and it's a lot more work.
      Had the bike serviced they couldn't figure it out. They swapped peticock, plug, new gas, all new lines, new throttle, and cable. Said the carb was fine, and clean. New air filter, said fuel pump was fine, no leaks around carb boots, new battery, new rectifier.
      Ran some sea foam through it....Runs Great.....Just such a pain to start...
      Thanks
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...