Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Recommended Posts

here in ft mac, we had the rains a week and a half ago, now southern alberta is getting hit hard ... with lots of damage (20 billion worth) and 3-4 dead ....

1_zpse2db5832.jpg

2_zps3142906e.jpg

these 2 pics are from ft mac ...

3_zps708810f6.jpg

4_zpsd1f74147.jpg

5_zps22754684.jpg

these 3 pics are from canmore area - banff area

6_zps49e945e2.jpg

11_zpsf5f39b88.jpg

7_zps67820997.jpg

10_zps83925442.jpg

8_zpsa8f766b4.jpg

13_zps717e54f3.jpg

12_zps7207776b.jpg

14_zpsa50e73b8.jpg

9_zps6da3f59b.jpg

16_zps1855c283.jpg

15_zpse9d41d38.jpg

17_zpsfd140f25.jpg

these pics are all from calgary, the saddledome is expected to have water up to the tenth row of seats ... a couple more ...

20_zps8a5a3372.jpg

19_zpsa06f88fe.jpg

18_zpsf71662a6.jpg

all these pics are on facebook via 2 pages, meanwhile in alberta and fort mcmurray aviation

Share this post


Link to post
Share on other sites


You need one of them big old snorkels on your quad for riding in that. Well wishes for everyone affected by it. Mother Nature seems pretty pissed off lately.

Share this post


Link to post
Share on other sites


Guest alexandermcnight

hoping that everybody is well.Relatives and friends..be safe always.

Share this post


Link to post
Share on other sites

Hope everything is starting to look better now as it is a massive clean up underway!

Thought are with you all

Share this post


Link to post
Share on other sites

That was some nasty flooding. Friend of mine drives city bus there and she was flabbergasted by the flood and devastation. Hope all were and are still safe.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Tagged Content

  • Similar Topics

    • By Maddie3142005
      Bet you've never seen a Tonneau cover that can hold 2 - 4-wheelers on top of it. This is a home-made heavy duty fiberglass truck bed cover that was used on an 2000 F-350 with an 8' bed. We have used it hundreds of times but are getting out of the 4-wheeling fun. You can waterproof with a rubber seal, not included. This leaves the area under the cover open for all your gear and firewood. It is white and in great shape. 4-wheelers NOT included.








    • By AKATV
      For those that have been pulling hair out-
      It took me a month to figure this out, but I am glad to report that I have figured out how to repair my 2004 450ES Speedometer

      If you have a Honda Foreman 02-04 450 ES model ( 4 indicator lights on top of meter)
      or a Honda Foreman 99-00 450 ES model ( 3 indicator lights on top of meter)
      or aOnda Rancher 00-03 TRX350ES

      and your display:

      - Is Blank

      - does not show the gear indicator spot at all (not the gear or --) but the
      backwards "L" that goes around the gear position - its just blank

      -your miles and hours have reverted to zeros or all 9"s and possibly now shows KM now instead of Miles

      -your speed shown seems to have almost doubled (possibly KMs per hour even thought it shows Miles)

      What has happened is your EEPROM chip on motherboard has lost the programming due to dead battery for
      a LONG time or an electrical malfunction etc...

      I have borrowed a friends speedometer (a trusting friend) removed the chip from his, copied the data and put it on mine and it reads perfect now.

      I can repair your speedometer it will have 1851 miles and 317.2 hours on it as that is the only copy I have for the 02-04 Foreman 450ES
      I can also do 99-2000 450ES speedometers (3 indicator lights on top of meter) but will have to double-check check on the mileage/hours copy I have and let you know to see if you want that

      I can also do TRX500FM and FE meters and the older Rancher 350ES meters as well but it has to have the above symptoms and not water damaged-caught on fire, cracked lcd, etc....

      If you have one you want repaired just send to me (just the board with LCD) I can repair it for you for $45.00 or barter if you have a second bad meter for parts
      Shipping would be 4 - $5.00 for First Class with tracking and I will pay return shipping
      I will confirm and send pictures to you as well to show a working completed repair on your display
      If there is heavy water corrosion, rust and rot damage etc.. its probably not repairable but I can try if you want -no fix-no pay
      If you PM me or whatever we can work it out I am easy and like you all I am always fiddling/learning with wheelers
      I think you will be happy and you will have more hair -mine is filling back in...................
      Message me if interested
       
      I am now also doing burned out screen repair if your screen has become unreadable due to UV sunburn damage from the sun
      It will appear burned or melted.
      The cost is 45.00 with same or next day turnaround
      Will do partial barter if you have a second speedometer for parts
      PM me if interested
      Before and after pictures below


    • By edb6969
      Hey yall,
      Is any one on here from southern california?
      Im from San Diego .
      Looking to see if anyone from my area is here.
    • By edb6969
      No one here go to glamis Ca.?
    • By richard fischer
      I have a new 2020 cforce 600 touring and read how smooth the shifting was on it. Mine however, sticks in gear quite often and only after moving the bike around does it finally shift. I use the brakes before shifting as it says but that doesn't seem to affect it either way. Anyone have this issue? Is there an adjustment on the linkage perhaps? Any suggestions are appreciated. The machine is new with about 10 miles on it.
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...