Quantcast
Jump to content

08 Polaris


BuckBilly

Recommended Posts

Here are some 08 Polaris Models.

1. Sportsman 800 and 500 Touring models(EFI)

2. Sportsman 700 and 500 X2(EFI)

3. Sportsman 800 EFI,500 EFI,500 no EFI ($5,999)

4. MIde size class the Sportsman 400 and 300 H.O.(Formally the Hawkeye.)

5. 450 Outlaw

6. Outlaw 525 IRS and Outlaw 525 NON-IRS

These are most of the models for 08 , not a complete list.

Link to comment
Share on other sites

  • 1 year later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Forum Topics

    • By hardcastle
      My friends KQ 300 starts fine and runs, as soon as you put it in gear and try to accelerate its bucks and farts like crazy, not moving... I cleaned carb and it worked good for 1 day... now back to same problem.... could it be such as a bent valve????
    • By Louznmemind
      Howdy y'all, I'm trying to fix a neighbors 2015 Brute Force 300. Came in with hard to start and won't idle except on choke issue. I pulled the carb and found the pilot jet as well as the emulsion tube partially clogged. Cleaned up everything, put it back together, still having issues...  It will start right up on choke and will also start off choke if you give it just a touch of throttle but it absolutely will not idle unless it's choked just a touch. Also, excuse my ignorance but I'm assuming the "dial" thingy attached to the carb that turns in and out is for setting idle?? 
    • By Its-always-something
      Have a 1998 AC 300 2x4, Just installed a new carburetor. Engine starts easy but the choke RPMs are very hi and take along time (5-10 mins when cold out). After engine has warmed up choke releases and it idles and runs fine., It does no have an electric choke. The choke lever is never used and it seems like an auto choke? Long story short, how can I lower the choke rpm levels?
       
      Also, carb came with a spare145 jet, not 100% sure what is installed. Could this impact choke RPMs?
       
       
      Any help and information greatly appreciated.
    • By Drillbit
      Hey all,
      I need some input on a problem I'm having with my Kodiak 400 that keeps fouling plugs. First off, I've done a lot of work to this thing, most of it all in good fun. Brake work, cv joints, u joints, carb kit, checked valve lash, compression good, changed all fluids, etc... My problem is it keeps fouling plugs very quickly. I can put a new (manual recommended plug) in and it starts right up, runs great, idles great, picks up good. Doesn't stutter at all. I ride it for 1/2 a mile, it cuts off and won't start back up. I let it sit overnight thinking maybe it got to hot. Try to start it the next day, nothing. Put a new plug in, fires right up, runs great for another 1/2 mile or so, dead. The plugs come out and look carbon fouled with dry black soot on them. I don't know if this is a fuel/air mixture problem or a ignition problem. A couple of things that I noticed is I never need to pull the choke out to start it. Also, when it starts it automatically idles high like an automatic choke would do, then it comes back down to a good idle. Also I noticed that the air/fuel mixture needle valve screw does nothing when I adjust it in or out. I can screw it all the way closed and the motor still runs and idles good. Any advice would be greatly appreciated. I'm almost leaning to a ignition breaking down the plugs??
      Thanks! 
    • By kantrud97
      Hello i have a 2005 Bombardier Outlander max xt 400, i recently split the case to fix a oil leak. while in there i took out the oil pump and i cant find the torque specs for the oil pump to go back in, i tend to over tighten everything so im trying to go be the torque specs so i dont break anything.
       
      Thank you in advance
×
×
  • Create New...