Quantcast
Jump to content

  • Do you own an ATV, UTV or SxS? Join our Community Forum!

    QUADCRAZY ATV Community and Forum are FREE to join! We keep our ATV, UTV, and SxS forums clean and user friendly. All first time posters in our forums will have to wait to have their content reviewed and approved. Once your first ten posts are approved, you will no longer need to go through a forum post approval process. To bypass the approval process with immediate access and a NO ADS experience in our ATV, SxS, and UTV forums, consider subsribing to a Premium Membership

2006 Joyner Buggy ( Phoenix)


Recommended Posts

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Forum Topics

    • By jashadams
      Hey all back again with my 1989 moto 4 250.
      After putting a new carb on it it's really sputtery, it has new gas and I'm wondering what to tune on the carb to make it idle better. I've attached a video to describe the issue more. The bike is still work in progress but I think the video gets the point across. Thanks!
      Snapchat-1142015191.mp4
    • By p5200
      Hello folks, my machine wound up with I think water in the tank etc. It runs but speeds up and slows back down randomly. When not running I don't see gas dripping  from the drain nipple on bottom of float bowl and drain screw is closed tight. With normal idle speed I see no leaking. When the idle speed increases quite a bit on it's own, gas appears to start slowly dripping from float bowl drain nipple? I'm wondering if the carb is flooding and the gas is actually coming from higher up and just appears, to be coming out of nipple but, is actually running down the sides of the nipple? I put a kit in the factory Mikuni carb last year after sitting for a while and I think the gas in the jug I used had drawn moisture. I plan to pull the carb tomorrow and clean everything out. I was just curious if anyone else thinks it's probably something in the carb and is, acutally a flooding problem? Thanks Folks! 🙂
    • By p5200
      Hello folks, I have a Polaris 500 Scrambler. Not positive I need a new battery.  The folks I got the ride from said they put a new battery on it right before selling it to me. It's been a couple cold months before I tried starting it. After jumping it now, I let it idle plus revved it quite a bit for about 20 minutes. Then I shut it off and tried to restart barely turns over and that's it? Am I not giving it enough charge time maybe need to actually ride it? The battery on it is a Continental CTX9-BX. I lf a new battery is needed would maybe Amazon have a decent one? Thanks!
    • By ResQ91
      Hi Guys!

      New member and could really use your advice. I would have to believe this has been an issue for others but a search here came up with nothing......? (Probably me not doing search correctly)
       
      I have an 87 Big Bear 350 YFM350FWT
      The OEM Mikuni BTM carb is shot and would rather replace than rebuild.
      It is no longer made and I have had good luck with NICHE carbs so I ordered a #K-CRB-0006 This was what they said was replacement when ordered. This Carb only uses 1 Throttle cable. The Slide is linked so it uses one. (OEM had 2nd cable coming through top to move slide)
       
      Problem is when I ordered a replacement Cable from NICHE (#C-CBL-0061) the Cable wire is a little short, not allowing Throttle to return all the way down to Idle position. I called NICHE and they are at a loss. Haven't gotten back to me after 2+ weeks.
       
      What would you recommend other than a carb rebuild?
      Can I just use 1 of the OEM cables (It is the right length) and snip/disconnect the other that went to top of Carb for Slide?
      Or ??
       
      Thanks in advance for any advice you have!!
       
      Dave
    • By GTX-Racer
      I am looking for a front battery cover for a Suzuki Quadrunner 250 (year unknown).  It has the headlight on the handle bars and no speedometer.
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...