Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

alanminz

New member here.

Recommended Posts



Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By technofarmer
      Hi there i was needing to ask a question. I may soon be getting a UTV of one sort or another and not sure what is good or better to avoid?  So far i hear great things about the Arctic Cat Prowler and Havoc, and many speak well of the Kawasaki Mule all but the 610?  
       
       So what are your thoughts and especially experiences?  What have you had and used in farm life and trail riding that has held up well or hasn't?        
    • By Chris Stokes
      What is a good option for a 13 year old that is dying to get her very own atv to ride? Thanks in advance for your recommendations. I currently own a Polaris Sportsman 570 and have been happy with the Polaris sportsman line but have ruled out other brands.
    • By BuckBilly
      Good morning to all !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
      Let's see if we can make this a daily event.
    • By dbconn55
      Hi guys I have a 2003 Arctic 250 4X4 it starts idles and runs great for about 10 min. then it spits and sputters and dies but it starts right up like nothing happened idles good till you give gas and it does it again let off the gas and it's idling great again this goes on for about 15 to 20 min. and then it takes off runs good all day like nothing was wrong.
      I cleaned the carburetor it looked like a new one inside found a little gunk in one orifice, new air filter no crimped lines air line to tank good I did put a meter on the battery idling it said 16.5 V that's high I think would a voltage regulator cause this?
      Suzuki shop wanted to sale me a stator for $556.00 but said it could be something else also thought I'd see what you guys say about it
      Thanks
    • By spock58
      https://www.100milefreepress.net/news/b-c-outdoor-clubs-get-funding-boost-from-province/
  • Similar Tagged Content

    • By Admin
      We have added a map of the 100 most recent visitors with their locations powered by Google. You can view it under the "BROWSE" section of the site. You can also click on the tacs to view who it is.
      Navigate to the "BROWSE" section, then to "MEMBER MAP" .
      Or click HERE :smile:
    • By Forrester
      Hi I have a 300 king quad breaking down when throttled . Starts and idles awe sum only revs up when I turn lights on and eventually blew high beam and then only revved on low which eventually blew .. Now with no lites no revs just idle
    • By biggreen2010
      hope I'm in the right place, not real good with forums yet, but its great to be apart of this forum:laugh:
    • By commander777
      commander777
    • By freforall
      Hi all, i come from from quebec, canada.....i use my atv for hunting
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...