Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Technician

2005 Suzuki Vinson 500 - Wiring Problems

Recommended Posts

it all started with the the negative terminal buzzing when i try to start it. in attempting to fix that now when i turn my lights on, on the four wheeler all power is shut off. will still pull start but would like to have all issues resolved. any ideas?

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Erik Plug
      Hi all,
       
      Picked up my first Brute Force yesterday. What should have been an awesome afternoon of riding turn a bit into a deception. As I was unable to really take it out for a test drive at the shop, I decided to buy it and agreed that I would take the test drive at home. 
      When giving full throttle I noticed that the Brute was choking and lost all of its powers. Faulty fuel pump most likely. 
      Called the shop and the are coming to pick it up and repair it and bring it back. Good service. Nevertheless feels a bit sour in the mouth as I was told it was a 100% good. 
      Need to have some patience I now before I can really start riding. 
      Cheers,
      Erik
    • By amharrison24
      i have a 91 moto 4 100. has electric start only. for as long as i could remember we have always pushed start it. after riding for while you shut it off. you are able to hit the start button and it will start right up. anyone know where i should start with fixing this issue? im fixing it up for my niece. thank you in advance.
    • By Steven Urban
      First time using this forum.  Owned a Kawasaki dirt bike once, had no issues.  But I picked up this 4 wheeler at an auction.  They stated it ran, but only needed a battery.  Well I do not believe that was all true.

      Some pictures are attached.  Not sure why, but the whole air filter stuff was removed.  They had some small thing inserted as a make shift air filter.

      I purchased a battery to try this all out.  Waiting to return it and get the proper size, as it was too big for the battery box.  But here is my issue I had while the battery was connected.

      1 - The lights on the steering column did not come on.  Not sure if they work or not.

      2 - The starter solenoid seems to be bad.  I have a new one on order. 

      3 - In the pick, there is another rusted part.  Not sure what that part is or what it is used for.

      4 - What is the 12v rectifier?  square bodied part.

      So when I hooked the battery up.  Pushing the start button did nothing.  Pulling the cord to try and pull start, it turned, but would never fire.  I have put in a new spark plug as well, it looked worn out.  With electric start, I crossed over the posts on the start solenoid, it turned over, but would never fire and start.

      I have read a few other threads and it stated something about needed the neutral light on.  SOmething about a kill switch.

      Any help would be appreciated.



    • By Chase Cook
      Hi I was riding my Honda the other day and I gave it gas for about a quarter-mile just flooring it and then it started to lose power. I pushed it about a mile home which was a pain in the butt but when I got home It still had gas, compression and spark. Do you think the timing jumped possibly?
  • Similar Tagged Content

    • By Michael Aiken
      Where can I find a wiring diagram for my 2005 450 Kodiak. Thanks.
    • By Mo Salem
      So my front hub broke, I’d like to put aftermarket on. Hard to find new oe ones. Please help. I’m new to all of this, I have some car knowledge and try to apply it
    • By oxidized_black
      tag : zukifreak
       
       
       
    • By LMI
      Was using the quad the other day to shuttle wood from my pickup to my wood pile.  When the job was done I turned off the Quad and heard a bit of a racket from the front end.  When I got down underneath the sound seemed to be coming from the fan housing.  fan was moving in spurts and not quickly... much like a computer case fan that's had it's day.  What I know.
      Temp sensor is ok, as the fan tries to activate fan is getting some voltage as it is attempting to spin.  When I first bought it used I tested the fan direct to battery and it was fine. The fan was working ok even not direct wired as I went on a couple of rides and when stopped and idling the fan did run Seems to be free spinning with my finger read up in the manual and they require me to drop the rad.  now I'm not opposed to that as the rad has some damaged areas I want to try and straighten out.  But if I can get the fan working without, I can leave the rad as it is until next year.
      Fan assembly is about 300 bills, any work arounds or alternatives?  I even thought large computer case brushless fan.  smaller ones are about $7 larger ones better quality probably far below the 300.  They run standard 12v DC.
      Anything I should be doing before dropping the rad... other than check for obstructions even though it seems to spin, and trying to hardwire it to the battery again for a test to see if it acts the same?
    • Guest Fox300exchic
      By Guest Fox300exchic
      The Hop-Up: You may be saying to yourself, “that’s a chick bike,” and you’re right. But honestly, it’s so much more than that. It’s one badass bike. http://www.quadmagazine.com/quad/features/article/0,24942,1587044,00.html
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...