Quantcast
Jump to content

  • Do you own an ATV or UTV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

2003 Suzuki LT-A400 Eiger Service Manual

   (0 reviews)

1 Screenshot

  • Like 1
 Share


User Feedback

You may only provide a review once you have downloaded the file.

There are no reviews to display.

  • Brute Force 750 KVF-750 Service Manual 2005-2007
  • Similar Tagged Content

    • By Stilllearning
      I'm tring to see if anyone knows if rear rack w
      Off 2002 suzuki eiger will fit on 2002 suzuki vinson..looks like it will wanted to get 2nd opinion before purchasing..thanks 
    • By TnMtnMn
      View File 2007 Suzuki LT-A400/F LT-F400/F Service Manual
      Acquired this manual when I acquired my 2007 Suzuki Eiger 400. 
      Submitter TnMtnMn Submitted 10/08/2021 Category Suzuki ATV  
    • By TnMtnMn
      Acquired this manual when I acquired my 2007 Suzuki Eiger 400. 
    • By Aleksandr Boreesenko
      doesn't idle at times but sometimes when it does as soon as I touch the throttle it just shuts off, what could possibly be the problem? I thank you very much for any help, Thanks.
    • By Sled Dog
      Hello Team!  Hopefully someone can help me.  I've been to the Suzuki forum and its pretty dead.  I should have been on this site a while ago as I own a Canam, Hondas and a RZR!
      Anyways issue is the ATV won't start.  Friend gave it to me to try get running.  They installed a Amazon carb and machine did the same thing.  This machine has 1100 miles and is not beat.  Appears to have led a gentle life.
      So the first thing I did was ask for the original carb.  They do have and brought it over.  But first I changed out all the old gas and put new in.  Got it to start but would not idle.  But could ride it around yard.  Its a manual, went through all 5 gears.  Runs like normal but would not idle.
      So I got a Shindy rebuild kit and rebuilt the original carb.  Reinstalled and almost the same thing.  Starter spins and it tries to catch but doesn't until it does.  Then it seems to run ok.  Idles high but after a while it will go down.
      So I take tank off and give a very good cleaning.  Took off the fuel petcock.  All looks good.  No fuel in the vacuum line so I believe its working as it should.  Cleaned carb again.  Adjusted valves.  Did not need.  Reinstalled everything and same exact thing.  Spins like a maniac for 10 or more seconds before it will start.
      Spark plug is black.  Brand new one too.  I checked the spark and did not see any.  Googled how to do it and I was doing it right, tried again, now I have spark.  Hmmm.  Kept checking and always had it.
      My battle plan now is to clean the Amazon (Chy-na) carb and install that one.  If it does the same exact thing I'll figure its not the carb.  If it does something different this will tell me nothing as I don't trust the Amazon carbs!
      But now I've read that these models Eigers have issues with the fly wheel magnets coming loose.  And affecting spark.  Anyone know if this sounds right?  Maybe if the spark is out of time it makes it harder to start but once started the running engine can overcome that?
      Oh yeah, compression is 130, spec is 142.  Not sure I trust my Harbor frieght compression tester though.  I'm bringing it to work to get the gauge calibrated.
      Sorry so long winded but I like to give all the details I can for the people in the know!  Anything anyone can suggest I do?  Thanks for your time!

×
×
  • Create New...