Quantcast
Jump to content

bassplayer1972

Members
  • Content Count

    13
  • Joined

  • Last visited

Everything posted by bassplayer1972

  1. Thanx Quadmaniac. I'll enter this one then.Gary
  2. Hi Keywil from a fellow Canadian and moose hunter. I'm in Penticton B.C.. Good to see you here. I'm a newbie to this site too and the help i've received from the members on this site since i joined back in October is awesome and priceless. I'm sure you'll find whatever you're looking for right here. Gary
  3. I call my entry "Disney on Ice." It looks like my quad has eyeballs like they would have in a Disney cartoon. Gary
  4. Thanx Bioware. I've checked Ebay. There's a few on there but i will probably just step up and go buy a new pair here. What i hate about Ebay is how an item costs more to ship than the actual price of what it's worth. I've seen small items on there going for $10.00 but they charge you $25.00 for shipping it. In some cases, they wont tell you how much the shipping is and when you win or buy the item, then they give you a ridiculous price for shipping to bleed as much money out of you as they can. Now i ask them how much to ship it before i bid or buy.
  5. I apologize if this is in the wrong section. I tried using the classifieds but i live in Canada and didn't get an option for B.C.. Anyhow, i have Ignition hand warmers on my ATV. The left grip is fried so i'm wondering if anyone out there has a used pair of hand warmers they want to sell me or a single Ignition hand warmer grip to replace the fried one if they have one laying around that they have no use for anymore? I trust the mods can relocate my thread if i am in the wrong place for posting this. Thanx. Gary
  6. That's cool Raptor. I see they have quite a few parts on Ebay for my make if there's something in particular your friend is looking for but i will keep it in mind when the time comes for your friend. My hunting buddy has an 1982 ATC Honda and he can't find parts for it. I told him to go on Ebay and there were tons of parts for his bike. Mostly used parts though as they don't make them trikes anymore but the people selling the parts obviously can't be bothered fixing theirs up for lack of parts either so they just sell the bikes in bits and pieces. Gary
  7. Hi everyone. I guess i should introduce myself now. When i first joined back in October, i was looking for help with my ATV starter. All it needed was brushes and i would like to thank everybody that responded with their comments. I primarily use my quad to hunt with but i do love riding in the off season. It's a 1994 Yamaha Timberwolf 4x4 250. Hope to upgrade when i get my truck paid off. I hope to learn everything here about working on and repairing my own quad instead of bringing it to a dealer and paying $70.00/hour. Anyhow, i'm happy to be here and look forward to talking to everyone and learning from their experiences. Gary
  8. I think those people should be exposed WillyPoP. They give us law abiding riders a bad name and put us all into one category as a whole. I get a local hunting magazine here in British Columbia and every year after hunting season they have a section called The Wall of Shame. They print the names of anyone and everyone that had broken wildlife laws from that year from poaching to polluting along with the offenses they committed to how much of a fine or sentence they received. I even personally knew a couple of people that had their name printed in there. Take a picture of them if you witness it yourself or post a clipping of when they did get busted and call the thread Idiot of the Week or something along those lines. This is part of the reason that they now want us to register our ATV's in B.C. so that it is easier to track these clowns down. Gary
  9. Since i'm in B.C., Canada, i guess i'll tell you they have just incorporated a law here to have riders license and insure their ATV's except if you're using it on private land. If you're a member of any game club or wildlife federation, then they automatically insure you as a part of your membership.
  10. Thanx DirtDemon. You are probably right. I've looked everywhere and can't see any. They aren't that big of a machine that you could miss any nipples if they were there. Mine being a 94 probably doesn't have any. I'll check my manual but like i was saying, the pics are terrible so i'll check the exploded pics instead. I'm just happy it isn't an electrical problem i'm having. I never could figure out what those circuit diagrams are trying to tell me lol. Thanx bud. Gary
  11. Thanx DirtDemon. I just wanted to try fixing it after the hunting season is why i took so long responding. I could of maybe did it during the hunting season but i'm notorious for forgetting how to put things back together and losing a part or two. That's why i got someone from maintenance where i work to do it for me. The advice given to me by you guys is great but i'm not too bright at some of this stuff to the point i would need to see it done once opposed to reading it and trying it myself. I do have a manual on disk that i bought on Ebay but i'm guessing the seller burnt all the copies of it because the pics on it are terrible and don't show you much. Thanx again for all the help and i'm sure i'll have more questions down the road. Here's one for you. Are there any lube nipples on my quad for a grease gun or is it a "take apart and pack joints with grease" kind of job. I get a squeak squeak squeak sound when i'm rolling to a stop or starting to gain speed. Thanx again. Gary
  12. Thanx guys for all your advice. I took the starter apart and the brushes were worn down to nothing. Replaced the brushes and now it fires right up. I appreciate all your help. I'm not very mechanically inclined and you all can talk circles around me when it comes to repairs. I began with the brushes because it would try to crank when i tapped the starter with a hammer. Same thing happened with my Toyota truck years ago when i had to hit the starter with a hammer. so i went on that hunch with my quad. Thanx again everyone. Gary
  13. I have a 1994 Yamaha Timberwolf 4x4. The electric start button worked fine when i was out hunting in the early hours of Sunday but in the evening all i was getting was a click click click when i pushed the starter button. Pull starting, it fires up no problem. I removed the battery and one of the cells was half empty so i topped it up and charged. Still goes click after i put the battery back in it. Posts are clean too. I heard that the starter brushes can be replaced. Thanx for the help guys. Gary

×
×
  • Create New...