Quantcast
Jump to content

jpjones789

Members
  • Content Count

    29
  • Joined

  • Last visited

Community Reputation

10 Good

About jpjones789

  • Rank
    Occasional Poster
  • Birthday 01/01/1990
  1. jpjones789

    jpjones789

  2. well my wall is fine. and i set the timing a few times and i just got new valves. and sorry for putting up so many postes
  3. ok guys so i have done alot that i can think of... i took my wheeler apart got new valves new rings and gaskets and then got it back together and i still only have 30psi compression. does any one no whats wrong..
  4. hey i need to buy some new parts.. so whats a good website to get parts that dont cost that much
  5. ya i have a book and the thing is great tells your everything.. i think im going to get new rings and gaskets. do you guys no a good website to get stuff like that.. that does not cost to much ?
  6. ok thanks man i think i also have to get new rings because when i was down there my rings were stuck in my piston so we took them out and cleaned them out and some one said after that happens most of the time the rings are not the same
  7. no i did not grind the valves down i asked a guy if i should do anything when i got my new valves.. he said just put them in the same way you took them out.. with the new parts i got i got valves locks and guides.
  8. i have the timing right i set it my self and i have a book to show me how to do it.
  9. ya it is. idk what could be wrong with it. i have like looked at everything i can think of
  10. ya i do have one and i got like around 30 PSI. and i have an 03 ltz 400
  11. so im having a compression problem i have looked at my piston, rings, cylinder, gaskets, and there all good.. but i got new valves and i set the timing.. what more could it be?

×
×
  • Create New...