Quantcast
Jump to content

Search the Community

Showing results for tags ' ltz'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Community Discussion
    • General ATV Discussion
    • General Talk - Anything Goes!
    • New Members Area!
    • Where To Ride Your ATV
    • ATV Picture and Video Sharing
    • ATV Racing & ATV Events
    • ATV & Off Road Modifications
    • ATV Tires and Rims
    • This vs. That ATV & Off Road Comparisons
    • ATV Trailers, Haulers, and Attachments
    • Hunting, Camping, & Outdoors Forum
    • ATV Laws, Legal Issues, and Policing
  • Regional ATV & Off Road Forums
    • Northeast ATV & Off Road Forum
    • Midwest ATV & Off Road Forum
    • South ATV & Off Road Forum
    • West ATV & Off Road Forum
    • Other Region ATV & Off Road Forum
  • ATV Manufacturer Specific
    • ATV Forums By Brand
  • UTV Side x Side Manufacturer Specific
    • UTV & Side by Side Forums By Brand
  • Other Powersports, Offroad, and All Terrain Vehicles
    • Kids ATVs and Youth Off-Road
    • ATC 3-Wheeler Forum
    • Dirt Bike Forum
    • 4X4 Trucks and Jeeps
    • Water, Snow & Other Powersports
  • QUADCRAZY Classifieds
    • ATV For Sale? Post it here.
    • Stolen ATVs
  • QUADCRAZY Supporters
    • ATV Links & Partners
  • ATV News, Magazine Articles, Product Reviews
    • ATV News, Articles & Press Releases
    • New ATV Products, Reviews & Tests
    • Manufacturer & Aftermarket Promos
  • QUADCRAZY Announcements & Support
    • Announcements/Support
    • Website How To & Feedback
  • Yamaha Grizzly Owners's Topics
  • New York ATV Riders's Group Forum
  • Michigan ATV Club - St Helen, Mio, West Branch, Rose City's Lets ride Michigan trails this season!
  • Michigan ATV Club - St Helen, Mio, West Branch, Rose City's Up coming season
  • Kawasaki Bayou 220 Restoration and Repairs's Topics
  • Ride Red's Videos
  • Ride Red's Ride Red Forum
  • NYC 2 Poconos/ Scotrun ATV Riders's ATV Upgrades
  • NYC 2 Poconos/ Scotrun ATV Riders's Quads
  • Mechanics Club's Topics

Categories

  • ATV News and Articles
  • ATV New Products & Reviews
  • ATV Racing & Events
  • ATV Ride Reports

Calendars

  • Community Calendar
  • ATV Racing Events
  • ATV Poker Runs and Riding Events
  • ATV Swap Meets
  • Other ATV & Off Road Events

Categories

  • ATV Repair Manuals
    • Arctic Cat ATV
    • Can-Am BRP ATV
    • Cannondale ATV
    • CFMOTO ATV
    • Hisun ATV
    • Honda ATV
    • Kawasaki ATV
    • Kazuma ATV
    • Kymco ATV
    • Polaris ATV
    • Suzuki ATV
    • Textron Off Road ATV
    • Yamaha ATV
    • Other ATV
  • ATV Owner Manuals
    • Arctic Cat ATV
    • Can-Am BRP ATV
    • Cannondale ATV
    • CFMOTO ATV
    • Hisun ATV
    • Honda ATV
    • Kawasaki ATV
    • Kazuma ATV
    • Kymco ATV
    • Polaris ATV
    • Suzuki ATV
    • Textron Off Road ATV
    • Yamaha ATV
    • Other ATV
  • UTV Side by Side Repair Manuals
    • Arctic Cat UTV
    • Can-Am BRP UTV
    • Hisun UTV
    • Honda UTV
    • Joyner UTV
    • John Deer UTV
    • Kawasaki UTV
    • Polaris UTV
    • Textron Off Road UTV
    • Yamaha UTV
    • Other Brands UTV
  • UTV Side by Side Owner Manuals
    • Arctic Cat UTV
    • Textron Off Road UTV
    • Can-Am BRP UTV
    • Hisun UTV
    • Honda UTV
    • Joyner UTV
    • John Deer UTV
    • Kawasaki UTV
    • Polaris UTV
    • Yamaha UTV
    • Other Brands UTV
  • Other Files

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Location

miles from

About Me


My Garage

Found 31 results

  1. I recently purchased a 2005 Suzuki LTZ 400, for the first few days it ran like a champ but now when it gets hot, no matter what you do, it will stall out when you stop. Even going from 2nd or 3rd gear it still stalls out. It still runs perfect, it just stalls when I hit the breaks (hard or soft). I don't know much about quads so I could use some help.
  2. My 2005 ltz 400 motor breaks up the faster I go. (3rd, 4th, and 5th gears). I've only changed the plug. What next. At first it was acting like it was locked up, but I finally broke it free, so it's not seized up. But there's a funny sound coming from it and it doesn't turn over as easy. Any ideas as to what might b wrong?
  3. i have owned it about 6 months went through three starters sumthing keeps chewing the teeth off of the starters put new starter gear in it twice too just cant figure it out works alright for a little while then starts messin up the engine seems to backlash when i shut it off too once its running it runs great though tired of buying starters
  4. Starter is turning but the gear to turn the crankshaft spins freely. It does not turn the engine over. Is there a shear pin or do we have deeper problem?
  5. ok, first time on here so be patient please and im sorry if i forget anything or have to much. ok so i have a 2007 suzuki ltz 400. first thing was that it all of a sudden just starting acting weird. it has all of its power when running fine but it has moments to where it acts like it is starving for gas. it will run then it just wants to die. then i can wait 20 mins and ride it and it will b fine for a little bit for like 20 mins of riding. and that started happening first. then i got a yoshi slip on and put it on and then took it to the sh op and got the carb cleaned and jetted for the slip on. changed the oil and etc... then after it got rejetted it ran fine for a day meaning about 1/4 of a tank of gas. then same thing starts happening. so i figured something got stuck in the carb somewhere in one of the jets, i cleaned the carb completely and cleaned out the petcock and tank. still doing the same thing. just taking spells from one start up to another. after that the only thing i did was was checked to see if it was geting gas to the carb and it is. so i dnt know if it could be in the electrical like the cdi or what, Please help im desperate to get it fixed before warm weather. if you need other information just ask. Thanks
  6. Is there anyway to get the Pinion bearing out without the special tools the service manual calls for? I have not been able to remove the pinion gear shaft coupling joint yet to get to it. Cant figure out how to get that off either.
  7. According to some people my swing arm bearings are shoot, so I bought some, they arrived about 5 minutes ago, Does anyone know if these bearings are press in? Thanks, LTZRider14
  8. every time i let this bike sit for awhile the bike will start but wont rev. the only thing that has worked is taking it to the shop and having it professionally cleaned out with ultrasonic cleaner 150.00 : ( really?? is there no other way to keep this thing running more dependable??
  9. I was looking online and seen the clutch kits for my fourwheeler (2005 LTZ-250). I am interested in the kits and was wondering if anyone on here knew if they were any good? Or worth the price? Thanks, LTZRider
  10. i have a 95 ltz 400 and i took it too turkey bay here in Kentucky the other day and it was running great and taking on everything like a champ. then i went through a few deep puddles and shortly after that it just died. i restarted it and it ran for a few feet and not at full power and died again. i kept trying to restart it and when it would start i would hit the throttle and it would die. to me it seemed like there was something clogging the gas line so i took everything apart from the tank to the carburetor and there was no blockage. i took off the carburetor tonight and cleaned everything i could get to on it and reinstalled it and it started up but only ran for a min before dying once again. any ideas of what i might have done and if i need to take it to a shop to get fixed or if i can just do it myself. i really need help with this one....
  11. I bought a 2005 ltz 400 yesterday i took it for a spin around my block when i came to stop it shut off and wouldnt turn off. I tried turning it on but would make a clicking sound from under the seat. The fuse is fine i already checked. Also the battery wires are tight im not sure what is wrong with it this is my first motorcycle lol
  12. anyone ever wash rings out? bike went from running completly fine to crank no start! bike has good spark, new plug with a known good swapped coil; no air restrictions, and plenty of fuel/starting fluid! haven't checked compression but with valve cover off and spark plug tight! i can watch cobustion smoke come up through the crankcase while cranking!!! so something ring or piston wise is going on! bike has always ran fine mechanically and never had engine issues!!!! and i mean never!lol now this is all after a fairly long periodic crank with choke on and off from crank to crank!!! this is why i think i may have lost ring seat but not sure if anyone's had this issue this way? - now for the one thing that has worked, i took spark plug back out and proceeded is if i were doing a wet compression test! (about a half a pint of oil in the hole!), mixed in with a decent dose of starting fluid down in the hole,lol, put plug back in, cranked it; FIRED AND RAN FOR BOUT THREE SECONDS;UNTIL MIXTURE WAS BURNED! the bike literally sounded like a 250ex lol very low compression run..... ......... does this sound like washed out rings or does anyone have diff. thoughts? if so are there any easy remedies for a fix! by all means not one bit affraid to put a set in but just figuered i'd ask!!!!! thanks for any help!!!!!!! -Frank
  13. On a cold start with the choke on full, the bike will start and run but only for a few seconds. Then she dies. I can use the throttle with or without the choke to keep it running but she won't run past a few seconds with the choke on alone. It will stay running after I play with the throttle for a few seconds. Just doesn't seem right. Any ideas???
  14. I can't get my sons ltzs carb adjusted properly. The carb has been cleaned and re jetted as per the dynojet instructions and i still have the hanging idle. I can get the idle to come down quickly but only by lowering the idle to a point to where it won't stay running. As soon as I raise the idle to anywhere betwen 1250 and 1500 the hanging idle is back. The bike revs up fine and then just won't return to the set idle without hanging at higher rpms for a bit. Every shift is like power or speed shifting. I have tried numerous jets and adjusting the fuel screw with no luck. Any insite would be appreciated. Thanks.
  15. Hey guys I am thinking about buying my wife a new quad I found a 2009 LTZ 400 the fuel injected model, for 3500 the guy says it maybe has 5 hours on it and still looks brand new, or I can get a brand new 2008 off the showroom floor from a local dealer that still has some left from 2008 for 4000 out the door, just wanted to see what you all thought would be the best deal thanks!!
  16. have a ltz 400 problem starts and runs but stalls and completly shuts down almost like turning off the key can anyone help me. this bike is completely decked out aftermarket everything I think the timing chain tentioner might be the problem it is the only stock part on the motor
  17. hey i got a ltz 400 and we just took it apart and we looked at the piston and everything it was all good and the rings were a little dirty so we cleaned them and put them back together but there was some marks on the piston where valves hit it. could a bent valve mess up ur compression ?
  18. Hey, I recent attempted a rebuild on my ltz 400. Upon putting it back together(cylinder and head are on) I went to put the cam chain guide back in, but I am having trouble getting the guide in. When I put the guide in it sticks up about 2 to 3 inches, getting in the way so I cant put the cams on. Anyone know whats going on? Was I supposed to put the guide on after putting the cylinder on, before putting the head on?
  19. As a lot of people know, the o3 ltz, kfz, and trx 400s came with a subframe that did not allow you to remove the grab bar and put on an aftermarket one like the newer models. I was wondering how in the world i can put on a new grab bar on my 03 z400. Is there a special type of grab bar for them or something?
  20. have a heavy modded 04 z400. just put a new battery in, turned the key on and the lights came on and then hit the start button. nothing and I mean nothing happens when I hit the start button. no clicking not starter motor nothing. any help suggestiins fixes would be greatly appreciated.
  21. I have 2004 suzuki ltz 400 It idles fine but as soon as you get on the throttle it chokes out. It is not a fuel/carb problem. i have narrowed it down to electrical problem due to the fact that when I get on throttle it draws more power the quad shuts off. I think it is the magneto or voltage distrubtor. Also it runs fine only when the key is turned so lights are on. If turn key to lights off mode. the quad will die. any suggestions
  22. I bought this quad about 2 months ago and it runs great. When I bought it the guy said all it neede was rear brake pads. I put new pads on it only to come to the realization that the rear master cylinder is frozen. I bought a rebuild kit for the cylinder and had the cylinder working until I put brake fluid into it. I put dot 3 brake fluid in it and tried to mount it and it had seized up again. I tokk it apart again and now the piston won't go back into the cylinder. I was told that the dot 3 brake fluid may have swelled the gasket on the piston. Can this really happen? Any help or suggestions would be awesome. Thanks!
  23. have a 06 ltz 400 frame is JUNK the rest is great found a 03 ltz 400 frame will i have many or any problems switching this over putting all the 06 stuff on a 03 frame please help i dont want to get it and find out suzuki did this or that diffrent in 03 04 05 06 07 08 etc.....
  24. I have an LTZ Quad sport 400 that the battery won't stay charge while riding trickel charge all night ride for a few hours then dead have to jump with truck and charge for a few then can ride a little while longer yill fan kicks on then shuts off again checked volatge out seems to be at idel 11.41 or so rev up about 12.13 can anyone tell me what voltage is supposed to be and this is voltage from mag or gen not from regulator side
  25. I just picked up a 05 LTZ 250 Quadsport 2wd and the u-joint in the driveshaft is shot. I have replaced u-joints in automobiles many times but never on an atv. I'm hoping someone can give me some pointers. 1st I need to know how to get the driveshaft out to replace the u-joint. On vehicles you remove the bolts from the pinion flange and slide the driveshaft out of the tail of the tranny and theres you shaft removal. Unfortunetly the wheeler is not setup like that. If someone can help that would be great.

×
×
  • Create New...