Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Sign in to follow this  
gregj49

2005 arctic cat 500

Recommended Posts



Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Topics

    • By Trent Finnessey
      So I’ve got a 2000 Honda 400ex absolutely love it!! I’ve had it for about a month, I ride with bruteforce 750’s, outlander 850’s and 1000 sxs’s and I was thinking of getting a trx450r carb and a full hmf exhaust. And probably doing the air box mod too, how much power would this give my 400? Just a little different or a big difference? Cuz if it’s not much of a different I’ll just stick with my dg slip on..... thanks!
    • By WIJBIRD
      Good morning!
      I have a 1999 Yamaha Big Bear 350 4X4 and I need to rebuild the carb. I have the dual-cable throttle model and I'm having a terrible time finding the correct kit for it. I'm not opposed to replacing it, but the only ones I'm seeing do not have the dual cable throttle system. Any help would be greatly appreciated.
      Thanks,
      Jay in WI
       
      P.S. I can send pictures if necessary.
    • By mybeavah
      Let's just say there was a little fire on the old Griz and the carburetor didn't do too well. Is there an aftermarket carb on the market or do I have to go Yamaha to get this?
      Thanks in advance
      Shawn
    • By JacobSlabach
      picked up this pos bike for $80 not running.  took it home, cleaned the carb and bypassed the fuse-  ran great (other than the rev limiter- those things are so stupid)  Then one day out of the blue it starts flooding on cold startup and wont idle cold, but idles to fast warm.  (too fast being about half throttle speed heh).  I tried a new carb ($10) and new sp.  new carb wouldnt make it run except on choke and then it was gushing white smoke.  I had better things to do with my time so I parked it in a shed and used it for a work bench for a while...  this last weekend, I wanted to take it along with the sportman to a mens retreat to let the younger boys have some fun on it--  took about 30mins to pull all the crap I had accumulated on it and then rolled it down to my workshop, put the old carb back on after adjusting the needle clip up two notches (leaner) and threw it back on the bike.  Will turn over, but no fire.  I didnt have time to check sp that day but just wanted some incite on what could be wrong with this quad (if it even qualifies as being called that)
    • By Dra O
      posted a while back - it was running at one point - I have all the plastic shroud off - it's down to frame and engine now
      -fuel pump: when line from petcock is attached, no fuel comes out other side to carb; the line to the carb is open (can blow through it); I thought when I cranked engine that the pump would spit out fuel on other side but it does not; I removed fuel pump and opened it up - diaphragm looks good - but internal areas had lotsa calcification build up - I cleaned this out and dried it good - the clear plastic pieces (?diaphragms) aren't broken - the spring w/ steel ball on end moves freely; am putting it back on tomorrow; but can anyone answer about the pump? isn't it supposed to pump fuel through it... to other side... to carb? puzzling
      -along with fuel pump: I replaced petcock 3 weeks ago (gas tank had rusty fuel in bottom - cleaned it out prior to new petcock); when I turn petcock arrow NOT to on or reserve, fuel comes out of line; when I turn it to on or reserve, fuel doesn't come out; puzzling
      -I don't know what's on back of fuel pump - it's a valve that has a hose coming out of it - looks like it goes to engine/carb - I haven't traced this out yet - what is it?
      -can squirt gas on air filter and engine will run for 2-3 seconds then stop - fuel in top of carb (under diaphragm) does same
      -it likely needs carb rebuild - will get to this - but something isn't allowing fuel to get from fuel pump to carb
      -I THINK it has a mikuni model x carb - diaphragm is ID 26mm  OD 68mm - hard to find inexpensive diaphragm, I guess because it's a model x
      -last thing - I replaced solenoid due to old one clicking; I HAVE to be charging the battery or it won't start/turn over - battery just goes dead; but if charging, it'll turn over nicely; i'm guessing it's a bad battery
      -any help appreciated - I've never owned an ATV before - inherited this beast from grandparent in-law
  • Similar Tagged Content

    • By Michael Aiken
      Where can I find a wiring diagram for my 2005 450 Kodiak. Thanks.
    • By Mo Salem
      So my front hub broke, I’d like to put aftermarket on. Hard to find new oe ones. Please help. I’m new to all of this, I have some car knowledge and try to apply it
    • By oxidized_black
      tag : zukifreak
       
       
       
    • By LMI
      Was using the quad the other day to shuttle wood from my pickup to my wood pile.  When the job was done I turned off the Quad and heard a bit of a racket from the front end.  When I got down underneath the sound seemed to be coming from the fan housing.  fan was moving in spurts and not quickly... much like a computer case fan that's had it's day.  What I know.
      Temp sensor is ok, as the fan tries to activate fan is getting some voltage as it is attempting to spin.  When I first bought it used I tested the fan direct to battery and it was fine. The fan was working ok even not direct wired as I went on a couple of rides and when stopped and idling the fan did run Seems to be free spinning with my finger read up in the manual and they require me to drop the rad.  now I'm not opposed to that as the rad has some damaged areas I want to try and straighten out.  But if I can get the fan working without, I can leave the rad as it is until next year.
      Fan assembly is about 300 bills, any work arounds or alternatives?  I even thought large computer case brushless fan.  smaller ones are about $7 larger ones better quality probably far below the 300.  They run standard 12v DC.
      Anything I should be doing before dropping the rad... other than check for obstructions even though it seems to spin, and trying to hardwire it to the battery again for a test to see if it acts the same?
    • Guest Fox300exchic
      By Guest Fox300exchic
      The Hop-Up: You may be saying to yourself, “that’s a chick bike,” and you’re right. But honestly, it’s so much more than that. It’s one badass bike. http://www.quadmagazine.com/quad/features/article/0,24942,1587044,00.html
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...