Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Sign in to follow this  
ATVNetwork

KTM’s New 300cc Fuel Injected Two-Stroke

Recommended Posts



Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Topics

    • By Alex91
      I have a 92 suzuki king quad that seems to be getting way to much fuel in my spark plug hole as I took out plug cranked it over and covered myself in fuel I cleaned carb and fuel filter and fuel pump all seems fine any other ideas
    • By Thomas Brooks
      I know...I feel stupid for asking.  I find it impossible to use the thumb throttle with my thumb when I have the bars turned full right. I have to reach across the top and grab the throttle from the front with my fingers. It isn't very smooth and I can't help but think that there must be a technique, mod or adjustment for this. How do I get past this?
      Thomas
      2017 Polaris Sportsman 570 X2
    • By Zach Jump
      Hello...first post.
      Have a problem I have not been able to figure out.  
      While back the fuel pump went out...replaced it.  I got maybe 30 minutes..maybe less before the new one went out.
      Replaced it again...same thing. Now I am sitting with two more new fuel pumps in reserve but do not want to experiment and blow out another until I have a clue of what could be wrong.
      Have checked electrical...seems to be fine but I am no expert. Also the fuse is just fine.
    • By Ron Young
      My 1990s KLF 300 has just developed this problem where if I turn onto full lock in either direction, the motor cuts out. It suggests to me either a short associated with the ignition switch, or more likely tension on a wire which is losing contact when pulled. To me this seems more likely because I would expect a short to show up as a flicker in the ignition light, which it does not.
      Before I strip it all down, has anyone experienced this, or could you advise me which wire/s to follow? Even though first look shows a number of wires in that are, I guess only one, or two would be involved. Thanks in advance.
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...