Quantcast
Jump to content

  • Do you own an ATV or UTV? Join our Forum!

    Join QUADCRAZY ATV Forum today for FREE! We keep these forums clean and user friendly. All first posters will have to wait to have their content reviewed and approved. Once your first post is approved, you will no longer need to got through an approval process. To gain immediate approval and a NO ADS experience, consider subsribing to our Premium Membership.

CF Moto 800 Quadzilla blown fuse


spavin
 Share

Recommended Posts

I had a problem with my CF Moto 800 It all started when a inline fuse blew melting the fuse holder 30Amp, the fuse was positioned right next to the battery

When I replaced the fuse the quad started but would not tick over and kept stalling.

has anybody else had this problem, and do you know why the blown fuse should affect the idle speed. 

Link to comment
Share on other sites

  • Admin changed the title to CF Moto 800 Quadzilla blown fuse
  • 3 years later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...