Quantcast
Jump to content


CF Moto U force 500 Snow Plowing


Dan Hanson

Recommended Posts

  • Ajmboy changed the title to CF Moto U force 500 Snow Plowing

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Forum Topics

    • By Spritee1
      having an issue with the unit when running under a load up a hill or in high gear, seems like the belt is slipping, there is a clapping sound coming from the primary clutch like it releases and snaps back in. i don't think I should have a noise like that. this is a friends unit and he has already replaced the primary twice with the same result.
      not sure where to look next
    • By mkibbe
      My 2014 750 king quad stalls sometimes when I touch or turn the handlebars,the problem has gotten worse,my machine has 475 miles and is only trail ridden,I have a new factory battery and i have 14.2 volts when the quad is running and 13.3 on the battery when not running,also using a multimeter there is no change in volts when turning the bars until it does stall,If I pull the 40 amp power steering fuse it will not stall.......I've been told its the ECU,Hate to buy one if thats not the problem,but its kinda leaning towards that,,,,,need some opinions.

    • By ethie
      Hi All
      I have a 2012 Coleman 500 Outfitter that keeps fouling out the plug within 10-15 minutes 
      not sure where to start
    • By rgeiser
      View File 2003 Polaris Ranger 400-500 service manual
      2003 Polaris Ranger 400-500 service manual
      Submitter rgeiser Submitted 04/18/2024 Category Polaris UTV  
    • By alexwv1863
      I have a 2016 Arctic Cat 500 and recently noticed some oil leaking on the engine block to the right of the oil filter. It's near two metal lines going in and out of the engine block. I think one of the lines is called an engine oil line. I have a photo I'm going to try and attach. Any help would be greatly appreciated. I don't want to start tearing into the engine if I don't have to. I think maybe a gasket or something blew around one of these lines. The ATV runs fine otherwise. Doesn't overheat or anything.

×
×
  • Create New...