Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Chomp

Frustrated

Recommended Posts

I've got a suzuki 250 4×4. I've gone there it almost entirely and it idles fine but when I give it gas it bogs down never winding tight. All it doesn't have is a breather box would a breather box cause this problem

Share this post


Link to post
Share on other sites


There have been  some  members found that without the breather box and air filter their machine does go lean  and bog as you say yours does.. You could try restricting the  air a bit either with  the  choke or just  by partially blocking the intake with your hand and see it it will rev up  ok .

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Mike Johnson
      Hello again guys ,. I have a Quadmaster that has a very bad lean to my passenger side wheel. I replaced the a arm bushings with no change in the lean,  I see no bent parts and no adjustments available. It's always been there since I got it but became really noticeable when I put the lift kit on it. I'm going to add a picture of the problem if allowed.

    • By jake Stillman
      Hello I am new to this forum and lt80s I have an 87 that has burned up 3 coil/cdi combos my question is can I out the newer set up on it and if so how do I do it I know they have different number of wires going to the cdi mine only has 2 please help
    • By Quadrunner44
      I have an older 1980s Suzuki quadrunner red lt 4wd (250)
      so just finished putting it all back together and was running fine just needed to adjust the rebuilt carb
      bf decides to hook up an air chuck to the gas tank because it got a shot of air in the gas line well 120psi didn’t agree with any of the parts including the new carb 
      end result : new battery new carb now it just clicks (one single click) won’t turn over 
      hard to pull start gets hung up (unless I remove the spark plug ) gas flooded out the first time but now does nothing purchases a new starter waiting the arrival 
      could there be damage to the crank shaft or pistons etc? Or install the new starter and try to fire it up ? What caused the starter to die after he flooded everything with gas was working fine. 
      Thank you 
    • By Flipper Tiffany Roper Jones
      All I have been through everything. Bought brand new.
      Throttle safety switch 
      Cam and rockers
      ECM
      Carborator
      Stator
      Fuel safety switch 
      Battery
      Everything every forum has spoken of I've bought sealed airbox completely tight unplugged black wire on trans. I have literally done everything in the book.Checked oil today full of gas anyone no anything what might b wrong. Next I'm taking head off and making sure valves seat any ideas.
    • By Bruce Madsen
      My 1999 Artic Cat 500 ATV has started bogging down and backfires shortly after starting.  Any suggestion for a remedy?
  • Similar Tagged Content

    • By mrfartsalot
      i have a 2001 suzuki quadmaster 500 4x4 that the primary cvt clutch is rusted on any ideas on how to get it off i want to try to reuse it if possible.
    • By oxidized_black
      tag : zukifreak
       
       
       
    • By Jason Magnone
      As stated above working on a 1999 Suzuki LT-F160. I think I’m having trouble with the carburetor. I keep fouling spark plugs. Full disclosure, I did make a poor attempt to “rebuild” the carb (that’s why I think that’s the issue). No idea if the new parts are at the correct “settings” (gaps and such) I believe the starting point is 1.5 turns from bottom out on the adjustment screw (is there another adjustment I don’t know of?).  Doesn’t feel like I’m getting gas drawn through the carb (clogged jet maybe?), the plug isn’t wet at all (assuming why they’re fouling?) Not a great deal of experience working on carbs and not having much luck on finding a lot of info on the 160’s.
      1st- by chance can I swap out the original carb (13200-02C03) for an LT 250 model (think the HA01050). They’re only about $30 apposed to $200. That would at least narrow down if it’s a wiring problem or carb issue.
      2nd - The wiring has been minipulated at least a dozen times (before I acquired it, my cousin got it from a buddy kind of thing). Hopefully don’t have to dig into this too much as it’s currently a bit if a mess. 
      I was told it ran last year... 
      Any imput would be greatly appreciated
    • By Ajmboy
      Pretty good video on the history of Suzuki ATVs if you are interested in some ATV education. Starts off from when three wheelers were the norm.
      Suzuki, A company with about 100 years of manufacturing history is company built on bold innovation and the courage to push forward with new ideas. One of these new ideas was created in 1983, when Suzuki invented the first four wheeled ATV and introduced it to the world. At the time three-wheeled ATVs were the norm, and Suzuki’s four-wheeled ATV the LT-125 created an al-new vehicle category and literally changed the industry.
       
       
    • By Chomp
      I' bought a suzuki from our local scrap yard I got it running yet when I give it gas it lugs down muffled both rear tires slant outward are that suppose to.  That act like bearings are bad I checked bearings and there goodbeari and there
       
      LT400fw
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...