Quantcast
Jump to content


04 Yamaha raptor 350 electrical help needed


Mario760

Recommended Posts

Need help my friend brought me his raptor to fix because it wouldn't start so I cleaned the carb and all was well till last night when I tried to start it again and there's no power and by power I mean lights don't turn on also won't turn over neutral light won't turn on either I checked the fuse and that's good and everything is plugged in battery is charged and I need help I cant find the cdi wiring diagram anywhere to test each cable so any help will be appreciated thank you!!!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Forum Topics

    • By mkibbe
      My 2014 750 king quad stalls sometimes when I touch or turn the handlebars,the problem has gotten worse,my machine has 475 miles and is only trail ridden,I have a new factory battery and i have 14.2 volts when the quad is running and 13.3 on the battery when not running,also using a multimeter there is no change in volts when turning the bars until it does stall,If I pull the 40 amp power steering fuse it will not stall.......I've been told its the ECU,Hate to buy one if thats not the problem,but its kinda leaning towards that,,,,,need some opinions.

    • By Suzukiquad
      If you had to choose one mod that you couldn't live without, or had to recommend one what would it be? 
    • By ResQ91
      Hi Guys!

      New member and could really use your advice. I would have to believe this has been an issue for others but a search here came up with nothing......? (Probably me not doing search correctly)
       
      I have an 87 Big Bear 350 YFM350FWT
      The OEM Mikuni BTM carb is shot and would rather replace than rebuild.
      It is no longer made and I have had good luck with NICHE carbs so I ordered a #K-CRB-0006 This was what they said was replacement when ordered. This Carb only uses 1 Throttle cable. The Slide is linked so it uses one. (OEM had 2nd cable coming through top to move slide)
       
      Problem is when I ordered a replacement Cable from NICHE (#C-CBL-0061) the Cable wire is a little short, not allowing Throttle to return all the way down to Idle position. I called NICHE and they are at a loss. Haven't gotten back to me after 2+ weeks.
       
      What would you recommend other than a carb rebuild?
      Can I just use 1 of the OEM cables (It is the right length) and snip/disconnect the other that went to top of Carb for Slide?
      Or ??
       
      Thanks in advance for any advice you have!!
       
      Dave
    • By luckyyyyesther
      Hey all!
      I'm on a mission to buy my first UTV soundbar as a gift for my dad(a newbie on ATV). I'm aiming for something that offers great sound quality without breaking the bank – my budget is around $250. Right now, I'm considering options like ecoxgear, kemimoto, and boss.
      Does anyone have experience with these brands or specific models that you'd recommend? Any advice or suggestions would be super appreciated!



    • By adr94
      Hello,
      I was able to repair most of the little problems on my 2006 BRUIN. I still have little things to do...
      I changed the Hazard light Switch because it was not locking when pushed and now it is not working at all. When I connect it (not sure of the wiring -4 wires but a lot of connection possible on this HELLA 3916-01 switch-) the flashing lights button (on the handlebar) is acting like the Hazard light switch.
×
×
  • Create New...