Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Daniel Donnelly

Suzuki LTA 50 frame VIN location?

Recommended Posts

Hi all could any of you good people help me with the VIN location on my daughter LTA 50 quadsport? There dose not seem to be much info about on these great little machines. Any help would be great thanks. 

Dan ☺

Share this post


Link to post
Share on other sites


Not sure of the 50's but the 80's have the vin stamped in the frame between the 2 front shock upper mounts.

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By BuckBilly
      Good morning to all !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
      Let's see if we can make this a daily event.
    • By Dean Walton
      Hi guys and thanks for taking the time to read this... 
      I've took my sons quad apart to tidy it up and replace the carb.
      Replaced carb sprayed exhaust etc.. And when I reconnect the battery I get no starter?? 
      I tried charging the battery and replacing it again to no avail.. On the battery ground wire there are two wires that seem to be pressed into the same connector. 
      I have read about a reset button under the wheel arch but can't seem to get it to work. 
       
      Here's a screenshot of the two wires that I think have been fused together circled on a diagram. 
       
      Thanks in advance. 
      Dean. 
       
       

    • By technofarmer
      Hi there i was needing to ask a question. I may soon be getting a UTV of one sort or another and not sure what is good or better to avoid?  So far i hear great things about the Arctic Cat Prowler and Havoc, and many speak well of the Kawasaki Mule all but the 610?  
       
       So what are your thoughts and especially experiences?  What have you had and used in farm life and trail riding that has held up well or hasn't?        
    • By HeWasRidinDirty
      I got this 400, that wouldn't start. It would try, but wouldn't catch. I checked the valves and the L intake was tight at .002. The compression came in around 120. It didn't improve after a couple of drops of oil into the cylinder. So,I figured it was the valve causing the problem. So, I got the valves squared away, but it still won't start. I checked the spark and it seems like it's getting an intermittent spark. It fires a few times then nothing. If l let up on the button and then hit again immediately, it will fire a few more times, then repeat. So, what am I looking at as a possibility? Electrical issues are not my strong point. LOL
    • By Chris Stokes
      What is a good option for a 13 year old that is dying to get her very own atv to ride? Thanks in advance for your recommendations. I currently own a Polaris Sportsman 570 and have been happy with the Polaris sportsman line but have ruled out other brands.
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...