Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

outlander560

Can-Am Rally Engine Problems!!!!

Recommended Posts

Just about 2-3 days ago my Can-am Rally wont start. I didn't run it though any water or mud. The power goes on but once i press the start button all i hear is a clank:aargh:. I checked the battery and it is fine. If anyone has any idea about wat to check please tell me.

Share this post


Link to post
Share on other sites


You could always get a voltage meter and start at the battery and work your way through the electrical system and see where it stops. Time consuming but it will pin point your problem.

Share this post


Link to post
Share on other sites

I don't think it will be the spark plug. The motor is not turning at all correct? It would have to be something in the starter or a relay somewhere.

Share this post


Link to post
Share on other sites


Sounds to me like you may have a bad starter or a connection problem at the starter. You can try tapping the starter a few times with a small hammer to see if get a reaction. Similar to a car starter, you may have worn brushes or a low spot the starter has stoped on.

Share this post


Link to post
Share on other sites

Also check the fuses. My Ozark done the same thing. There is a solinoid that clicks like a bad starter if I blow a fuse.

Share this post


Link to post
Share on other sites

i tried it, it was good i saw a little improvement but nothing. The fuse was fine also. So im going to take it to the dealer and get it fixed. thanks for the input.

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Bryzan3
      Looking for advice on what to try next I bought this quad and it’s has spark and fuel but won’t stay running only fires when I hold the starter button in even when spraying gas into the carb it still dies right away oil was milky white so I was thinking it maybe went under water 150 psi compression so I might be wrong but not a head gasket I am stuck Cause it should stay running with the straight gas through the carb so what should I try 
    • By mjm4jc
      Hello everyone,
      My Suzuki LT185 didn't come with a battery from the factory (no electric start). I was wondering if I would need to add a battery if I wanted to install some of those light bars/pods or should I just wire it in to the headlight switch? Will the generator be able to put out enough juice to run the light bar? Also, is it normal for the headlight to get dim at idle, then brighter when driving? Never had a quad before with just a generator. 
      Thanks!
    • By Bryzan3
      Looking for advice on what to try next I bought this quad and it’s has spark and fuel but won’t stay running only fires when I hold the starter button in even when spraying gas into the carb it still dies right away oil was milky white so I was thinking it maybe went under water 150 psi compression so I might be wrong but not a head gasket I am stuck Cause it should stay running with the straight gas through the carb so what should I try 
    • By donerightautomotive84
      Ok so 2000 sportsman new.caltric carb new fuel pump new jug and piston new cdi and coil finally get to start it and itll idep for 5 to 10 seconds and die what am i missing people any help id love ya forever lol
      Sent from my LM-Q720 using Tapatalk
    • By mkibbe
      My 2014 750 king quad stalls sometimes when I touch or turn the handlebars,the problem has gotten worse,my machine has 475 miles and is only trail ridden,I have a new factory battery and i have 14.2 volts when the quad is running and 13.3 on the battery when not running,also using a multimeter there is no change in volts when turning the bars until it does stall,If I pull the 40 amp power steering fuse it will not stall.......I've been told its the ECU,Hate to buy one if thats not the problem,but its kinda leaning towards that,,,,,need some opinions.

  • Similar Tagged Content

    • By weblex
      Problem: The ATV starts and runs at idle perfectly. But as soon as I open the throttle, the engine starts to slow down until it stops. On the attached video you can hear the sound of how it works: see video below
      Prehistory: there is a Polaris Sportsman 500 1998, which for about 1.5 years stood in repair, including also replacing CDI with one taken from the same ATV. Finally, the vehicles were on wheels, traveled several kilometers and overheated - forgot to fill the antifreeze Came back home in small moves. The next trip started well, but after 10 km there was a feeling of a small drop in power (even as the vehicle got warm completely) but still drives. Next trip - the situation is repeated. The next test of ATV through time and a huge loss of power from the very beginning. The engine sneezes, does not want to go more than 5 mph.

      What has been done: the carburetor has been replaced with a new one (inexpensive, $ 40), a new spark plug, a new ignition coil, the engine head has been removed, the piston is in good condition, valves were corrected - but the problem was definitely not in them.

      Ignition control unit is suspected. Who faced similar? Please help in solving the problem.
      Thanks in advance.
       
       
    • By JacobSlabach
      in this thread, I want to discuss how 4-cycle atv engines work- what the different types are...  how they are set up and which you prefer.  To start off, are the cams on ALL atv 4-strokes powered by a cam chain?  I know that on say a lawn mower or logsplitter engine, the cam is turned by the tappet, pushrods, and valve rockers.  Which is better and why?  Chain-driven cams or pushrod-driven cams?  Are the pushrods just an old version and everything is transforming to chains or the other way around...or not at all?  Just looking for some explanation, history, and downsides/upsides...
    • By mmgood
      Hey people
      Question for all, just picked a 1986 bayou 300 thinking of going synthetic any thoughts ?
    • By Arctic Snowdog
      Hi Guys,
      I have a small Sled Dog business and I train up to 14 Huskies pulling a Yamaha Grizzly 550, that is quite a lot of Horse (Dog) power. Sometimes in order to make the ride smoother for Dogs and us we ride in Neutral but on a few occasions I have noticed that the right hand (front) brake seems to loose pressure and does not brake at all. Is there a particular reason for this ? Is it a fault or is it something to do with us riding in neutral, I only use the ATV in this way a few months a year before the snow comes but I am sure I recall the same thing happening last season.
      Any ideas would be greatly appreciated because I am a far way from being a mechanic.....
      Have a super day and thank you all.
      Craig
      Lapland

    • By Wiktorix Gameplays
      Can I use an old snowblower engine in my 90cc quad? The old one blew up. 
      Thanks for the help. 
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...