Quantcast
Jump to content

New here


Julio Cano

Recommended Posts

On 2/20/2020 at 10:30 PM, Julio Cano said:

Hi Everyone
Thank you for welcoming me into the group. I am a new member  with a nice 1999 suzuki gsxr750 driver that I really enjoy.  Using as daily driver.

welcome to QC !!

42 minutes ago, Jennifer Schuler said:

Hello !!! I'm new here also. Just wanted to say "HI!" 

Welcome to QC !! 

  • Like 1
Link to comment
Share on other sites

  • 1 month later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Forum Topics

    • By BruceG
      Hi guys. I have a problem where the quad will start and run well for about 5 minutes and then it dies. On inspection the airbox has oil in it (quite a lot). The oil is pumping through the cylinder head breather hose. This problem first happened suddenly. I have since done the top end including, piston, gaskets, rings and valves. I have also done the carb (not that I thought that this was the problem). The compression seems normal. The only thing that I can think of, is that I did not grind the valves well enough. Anyone experienced this? If so, how did you fix it? Any other thoughts?
    • By hardcastle
      My friends KQ 300 starts fine and runs, as soon as you put it in gear and try to accelerate its bucks and farts like crazy, not moving... I cleaned carb and it worked good for 1 day... now back to same problem.... could it be such as a bent valve????
    • By Louznmemind
      Howdy y'all, I'm trying to fix a neighbors 2015 Brute Force 300. Came in with hard to start and won't idle except on choke issue. I pulled the carb and found the pilot jet as well as the emulsion tube partially clogged. Cleaned up everything, put it back together, still having issues...  It will start right up on choke and will also start off choke if you give it just a touch of throttle but it absolutely will not idle unless it's choked just a touch. Also, excuse my ignorance but I'm assuming the "dial" thingy attached to the carb that turns in and out is for setting idle?? 
    • By Gwbarm
      I have been exploring all the options available, so many, its hard to choose. I have kind of narrowed it down to the Honda Pilot, Subaru Outback, and Kind of looking at the Outlander, although its a little small,  the new one is nice looking. Just wondering if anyone has any recommendations or gripes with any of these rides. I have driven Jeeps for the past 25  years and they have been great, but their price point has gotten to high. Expieriences good or bad would be helpful. Thanks!
    • By DrtyGrlKristin
      Just thought I'd start a new thread for newbies to the site!
      If you're new here, tell us who you are, where you're from and what you ride!!!
      Lets get to know each other a little better shall we?
      I'm not new to the site, obviously, but...
      I'm Kristin from Denver!!! I ride a 2008 Yamaha Rhino. She's my muddy baby!!!!!! Several aftermarket parts on her. She's good to me! We try and ride every weekend. This weekend we're off to MOAB! :woot:
×
×
  • Create New...