Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Orangejbird

2003 Suzuki Vinson Water Pump Issue?

Recommended Posts

My Dad's 03 Manual Vinson has milky oil. He changed oil and ran it everyday for a week being sure to keep it running for an hour each time. Fresh oil is getting milky again..
Thinking it's the water pump seal. Has anyone here successfully changed the seal or even replaced the whole pump assembly?

Share this post


Link to post
Share on other sites


It could be on the lower portion of the cylinder head at the base.  
It could be the seal behind the water pump like you initially said. Problem is where to start????? Pick the least invasive path first which i think is the seal you mentioned.  

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

  • Similar Tagged Content

    • By Amboyjim
      Having serious problems with quad it completely stopped running on me took carb off and tore apart cleaned everything put back on and it started idled but when driving it had no power at all so took carb back off and noticed their was a puddle of gas and oil in the bottom of the air filter box and also their was gas in the vacuum line HELP
    • By Wayne Starz
      I have a 2005 Suzuki Vinson 500cc automatic 4X4. I can only shift it in to park & High gear, it will not go in low or reverse, what's the issue & the fix?
    • By Alex Lee
      Im having a problem getting the left side of my engine case apart so i can fix my starter gear issue .can anyone share some guidance i have all bolts that i know or havent managed to remove hi lo shifter 
    • By Jeff Allram
      Hello.  I'm wondering if I have to split anything to replace the rear u-joint on my ATV?
      Will the driveshaft pull out of gearcase, or does case have to be removed and split?

    • By mad_jack_jr
      I've changed my stator and pick up coil. I've verified new stator specs are correct and I have a good ground at the cdi. Also verified continuity from all stator wired to cdi and rectifier which is also new. I have a source voltage but no trigger voltage. It's a 2005 Arctic Cat 500 Suzuki Vinson motor. Any help would be GREATLY appreciated. I've spent about 2 weeks troubleshooting this and can't seem to find this exact scenario on any forum. Tjanx again for any input!
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...