Quantcast
Jump to content

1993 Polaris 350 Identification Help


Ttedd01

Recommended Posts

  • Admin changed the title to 1993 Polaris 350 Identification Help

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Forum Topics

    • By hardcastle
      My friends KQ 300 starts fine and runs, as soon as you put it in gear and try to accelerate its bucks and farts like crazy, not moving... I cleaned carb and it worked good for 1 day... now back to same problem.... could it be such as a bent valve????
    • By HSTAR
      Hey I have a 1997 big bear 350 4x4
      I replaced the shifter shaft and the shift arm linkage and the rod when I installed them all I was unaware that you had to line the dot on the shifter shaft with the gap on the linkage arm gap put it all back  together and rode it I can't get it to shift in the right gears  I can move the shift cam by hand and goes in different gears but with the shifter shaft in it riding I can't put it in R or N 
      Anyone know how to line up the shifter shaft and the shift cam s
       
    • By Sofaspud
      My 2008 can-am Outlander 800r is having hard shifting issues. Does anyone have a fix for this ?
    • By adr94
      Hello,
      I was able to repair most of the little problems on my 2006 BRUIN. I still have little things to do...
      I changed the Hazard light Switch because it was not locking when pushed and now it is not working at all. When I connect it (not sure of the wiring -4 wires but a lot of connection possible on this HELLA 3916-01 switch-) the flashing lights button (on the handlebar) is acting like the Hazard light switch.
    • By Am2007
      Hi everyone,
      Outlander 2006 400 XT i have replace the startor cover and right after i did that the oil light is on and not turn off, i check the wires and checked the oil level, everything seem to be normal quad is starting without any problem and rev just fine. i did not want to ride it since im not sure if it is faulty sensor or not so just be safe i did not let it run more the a minute or so. 
      I have read in the owner manual that i need to clean the oil strainer every 200hr unfortunately i never did that, my service manual that i have does not even indicate of such a thing. so i did some search around and it seem like canam split the manual into 3 parts
      owner manual
      service manual
      engine manual
      I have the first 2 but i can not find the last one, part number 219100232. If someone can guide me where do i find the oil strainer so i can clean it i will appreciate it.   im going to do an oil pressure test tomorrow to check how many PSI i have, just to make sure.
      Thanks
×
×
  • Create New...