Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Rooftop777

2009 sportsman 500 x2 blowing 20 amp fuses and speeometer flashing help

Recommended Posts

Can't figure out whats wrong, battery good, charging fine but speedometer needle flashing. I know my fuel sending unit is not working but atv was working well last year. Now it was blowing fuses. I did engine code check but none there. Gas gauge flashes and shows FUEL in capital letters. Need help as just cannot figure this out,

I might pull the fuel pump out and put new float as likely saturated. Don't know if that would give me all these problems ??

thanks

Share this post


Link to post
Share on other sites


Blowing fuses nearly always will trace back to bare wire causing direct short or overcharging by the stator.  I'd trace the harness starting at the battery and going forward.  Almost guarantee somewhere there is a bare spot that touches metal occasionally.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Brent Wright
      What was the last year of these quads?
    • By Kelby 746
      Hey y’all I got a kfx 400, rebuilt the carb put bigger inlets on it, adjusted the fuel mixture screw 2.5 turns out and cleaned the fuel petcock. It starts up not so great, it takes full throttle with full choke and cranks for about 10-20 seconds before it fires and while “ideling” it surges very bad and I’ve messed with the idle set and it changes nothing, if you ride it casually it runs fine but as soon as you get on it for more than 4 seconds it stumbles and falls flat on its face and you have to wait for the carb to fill back up with fuel, I’ve checked everything and nothing is blocking fuel, I even put a bigger hose to see if that made a difference. Thanks for reading hopping to hear someone has some advice. 
    • By mjm4jc
      Hello everyone,
      My Suzuki LT185 didn't come with a battery from the factory (no electric start). I was wondering if I would need to add a battery if I wanted to install some of those light bars/pods or should I just wire it in to the headlight switch? Will the generator be able to put out enough juice to run the light bar? Also, is it normal for the headlight to get dim at idle, then brighter when driving? Never had a quad before with just a generator. 
      Thanks!
    • By dpacapt
      Has anyone disabled the engine brake on their atv, or is it even possible?
    • By gmoose
      Fuel issue. Fuel runs through carb flooding  cylinder when sitting. Does the float suppose to shut the fuel off when sitting ?
  • Similar Tagged Content

    • By donerightautomotive84
      Ok so 2000 sportsman new.caltric carb new fuel pump new jug and piston new cdi and coil finally get to start it and itll idep for 5 to 10 seconds and die what am i missing people any help id love ya forever lol
      Sent from my LM-Q720 using Tapatalk
    • By Chase Cook
      Have a 2001 polaris sportsman 500 4x4 atv and when I put coolant in the radiator it starts leaking from the exhaust. The valves are sealed but it stopped making compression. Do I need to just replace the head? I just rebuilt the hole top end and this is the only thing +valves that I have not replaced and was wondering if that is why it's not starting up. Need answers please.
    • By Aaron Drost
      Hello bought my 2000 polaris sportsman 500 last week bike seems to work pretty good untill yesterday, when in reverse the bike seems to start bogging out? How come? 
    • By technofarmer
      Well its finally happened, its time to replace the belt on my 2011 Polaris Sportsman 500 H.O.   Is there anything specific i need to know before getting into it? Is there one brand of belt i should get over another?   I'm still on my first Polaris and plan to keep it at least another 8 years.   
    • By Christian Brindle
      I have a 2000 Polaris Sportsman 500. The Speedometer got water inside of it and it sat for a long time. So now that speedometer is trashed to say the least and i need to find a replacement. I don't want to put up the cash for an oem one so i was wondering if anyone knew any good speedometers out there i could use. I've found many speedometers i like but don't know how i'd wire it up without the same connection points. Thanks, any input is appreciated
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...