Quantcast
Jump to content

  • Do you own an ATV or UTV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

1998 Suzuki King Quad High RPM


Recommended Posts



Start with draining the float bowl on the carb and putting new fuel in the tank. I'm assuming this is the first time starting in a while? If so you've accumulated water in the tank and it found it's way to the carb float bowl. Water is heavier than fuel and will sink to the bottom. This new ethanol fuel sucks moisture out of the air and that's how the water gets in the fuel.

Link to post
Share on other sites
  • 2 weeks later...


  • 2 months later...

Well I found out what was wrong with my King quad I rebuilt the carburetor and it still had the same problem idle perfect but when gave it gas it had no power I threw in the towel brought it to the mechanic that works on ATVs and bikes. He found the problem it was an electrical problem he had to replace my rectifier ATV runs perfect now. 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Tagged Content

    • By Quad king
      I am not sure what is wrong with my King Quad. I had a new carburetor put in 6 months ago, just replaced the fuel pump and added an in-line fuel filter in. I have been trying to fix this quad for a while now and do not know what is wrong with it. It idles fine and runs great as soon as it is fired up, you can Rev it and stay in first gear with 100% power. As soon as I drive 10 feet it looses all power, I mean it is sputtering and doesn't move at all, but when I let off the gas after it sputters it idles fine. I will attach a video of what it is doing.
      Snapchat-1290161440.mp4
    • By Abbeypalm
      While cruising, my 2011 750 king quad suddenly shut down. As it happened, red lights on the display flashed. Any ideas? My head lights suddenly stopped working about a week ago, if that helps. I have no power at all. Thanks 
    • By smitht18
      Looking for the rectifier.  Most bikes have near magneto.  It appears the KQ has it in front.
      Can someone tell me exactly where it is? 
      Bike not charging and magneto checks out ok
    • By Clint Osborne
      2010 Suzuki king quad 750 axi 4x4 light stays on and 4x4 not working any suggestions thanks
    • By hornythrony
      Hey I have a 07 king 700 there's lots of times that the quad will stall when the fan turns on also have to bump motor 2 or 3 times before starting to start it (makes fuel pump go on 2/3 times) anyone having or had this issue?
  • Similar Topics

    • By Belmontie
      Hi bought a 2012 kingquad ASI last year a great machine which is a delight to ride, but I find sometimes it doesn’t go into top gear just revs high at about 42mph. Any idea ???

    • By raymonday1115
      Hey iv got a 2009 renegade 800x with no power at all no relays clicking no gages no nothing.
      I look at all the obvious places and found nothing.
      It was running and drove to where it currently sits and has been there for the winter.
      Any advice would be greatly appreciated.
       
      Sent from my SM-N986W using Tapatalk
       
       
    • By mpovah
      Hi all, new member here. 
      Picked up a really cheap non-runner last night from a neighbor. He had gotten it from someone else who had rebuilt it a few years ago and it has decorated his garage since.
      It is an early-90's (1992 or 93?) Suzuki LT250, but the weird part is the engine is a neon green color. I am now wondering if someone swapped the original motor out of this quad. Does anyone have experience with these that could give me a pointer as to what this could have come out of? I have heard that some Arctic Cat models had the same Suzuki motor - could that be where this came from? It is a 2WD, and has the typical chain drive/RWD system with both front and rear (rear drum) brakes. Very little rust and mostly complete, for the price I paid it isn't bad, but I am not sure how to pinpoint the engine type, and I would like to have that figured out.
      Just want to make sure what I am dealing with before ordering parts. I will need a carburetor by the looks of things, and air/oil/fuel filters, plugs, etc. 
      Thanks in advance for any help, appreciate your experience with these quads. 
      Matt
    • By tacojooper89
      Figured I ought to post a little introduction for me and my newly acquired quad. I just recently picked up a 1985 Suzuki lt250ef in pretty rough shape but a good price. Need typical things like tires, tune up, and a couple other things. Came to this forum looking for a service manual and maybe so parts. I'm looking for mostly the rear brake light assembly being as someone apparently decided to remove it at some point and bypassed the wiring. Also any pointers to typical good practices on these would be nice but I like to think I am fairly mechanically inclined. Any help is appreciated, thanks!
    • By JacobSlabach
      I have a gentleman that asked me to service his bayou for him.  I have always wondered what oil should be used in atv engines?  Pros?  Cons?  What weight should be used in what type of weather?  Is there one kind that I could bulk buy and safely used in any quad I worked on or owned?  What about performance?  Engine Life?  This has always been a 🤔🤔🤔 area for me with quads as far as why you would use one type of oil over another....
      Thanks!
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...