Quantcast
Jump to content

  • Do you own an ATV or UTV? Join our Forum!

    Join QUADCRAZY ATV Forum today for FREE! We keep these forums clean and user friendly. All first posters will have to wait to have their content reviewed and approved. Once your first post is approved, you will no longer need to got through an approval process. To gain immediate approval and a NO ADS experience, consider subsribing to our Premium Membership.

Artic Cat 400 4x4 400 has strange problems


Recommended Posts

I let my ArticCat sit over the winter but before it was put in the garage it was running perfect. In taking it out this year it wouldn't start. I can start it with a charger and it will idle just fine. But it's doing something weird now. Either the display 1)won't display anything or 2) it will just display the analog speedometer but none of the digital stuff or 3) it will display all. So it was acting really sluggish when in HIGH gear and sounded like it was in low gear. So in driving it down the road and it being sluggish, I switched the ignition key to "Lights ON" and the ATV immediately picked up as though it really was in HIGH gear. Switching the ignition back to "ON" was like down shifting into LOW gear. When I came to a stop and switched from LIGHTS on to just ON the ATV completely died. After a 30 minute ride you would think it would start again but I had to jump it again to get it to start. Same issues with the ignition having to be pointed to Lights for it to run decently. Then just as I got back to home base the display showed VOLT. It acts like it's something in the ignition but not sure how that's related to the gears. I put a gas cleaner in the tank since it's been sitting but it really doesn't seem like a bad gas issue that I thought it was at first. I checked the IGN fuse but it seems fine, replaced it with the extra fuse but no joy. Anyone have any ideas?? Thanks in advanced for any help. It's much appreciated. 

Edited by TSWIII
spelling
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share


×
×
  • Create New...