Quantcast
Jump to content

  • Do you own an ATV or UTV? Join our Forum!

    Join QUADCRAZY ATV Forum today for FREE! We keep these forums clean and user friendly. All first posters will have to wait to have their content reviewed and approved. Once your first post is approved, you will no longer need to got through an approval process. To gain immediate approval and a NO ADS experience, consider subsribing to our Premium Membership.

2005 Brute Force 750 smoking


kawman14733
 Share

Recommended Posts

hi im steve from ny and new to site i just bought a 2005 brute 750.with a 820 kit cames ported head dyna ignition 28 silver backs on it. 40 miles since the engine build with a totle of 810 miles it smokes after i do a few wheelies then if driven awile with no wheelies it stopes smokin is that a v twin thing oil level isint to high anyone have this problem other then me thanx steve

Edited by Ajmboy
Link to comment
Share on other sites

Dream Car Giveaway

Welcome to QUADCRAZY!

Its just something the V-twin motor does I believe when pushing for more power. Also, doing wheelies causes oil to go where it necessarily shouldn't and into the combustion chamber.

Make sure your oil is not over filled. Make sure there is no oil in the air box, that motor pushes oil into the air box from what I heard.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...