Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Raptorman224

2004 Raptor 660 New Clutch Adjustments

Recommended Posts

HI everyone. I ride a raptor 660 2004. I just had a new clutch installed last summer. I didn't ride much the winter but a few times on the ice and mud. So now its spring and i took it out again but i noticed that the clutch isnt catching very well. I hope the new clutch isn't gone, but don't you need to adjust your clutch as you break in your new clutch? Any help would be appreciated thanks!

Share this post


Link to post
Share on other sites


You should adjust the cable to reduce free play. There should be a minor adjustment at the lever on the handlebars. If you need a major adjustment, I believe further down the cable there is a an ajustment with lock nuts.

Share this post


Link to post
Share on other sites
You should adjust the cable to reduce free play. There should be a minor adjustment at the lever on the handlebars. If you need a major adjustment, I believe further down the cable there is a an ajustment with lock nuts.

Exactly what AJMBOY said. Have you been able to adjust it?

Share this post


Link to post
Share on other sites

Hey Raptorman, any updates?

* Changed your thread title for more relevent searches.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By LTZ-Zach
      So i was riding the other day and my quad randomly shut off. It started back up and ran completely fine for a little while and then it started idling terribly.
      I cleaned the carb and changed all the jets and everything except the float due to the rebuild kit not coming with one and it actually runs worse then it did before.
      It will run and idle decent now but when I give it gas it dies.
      Does anybody know what could be wrong?
      I also changed the spark plug and air filter along with the oil and oil filter.
       
    • Guest Fox300exchic
      By Guest Fox300exchic
      If we had a dollar for every time the question “Which is really faster, the 700 or the 450?” shows up in our inbox, mailbox, or voicemail, we’d be putting this magazine together from a bungalow on a barely inhabited tropical isle named Quadhama.
      http://www.quadmagazine.com/quad/features/article/0,24942,1603755,00.html
    • By Snowden
      Hi everyone,
      I have a question, if the starter clutch gear looks fine but is still not working correctly then all I should need to replace is the one way bearing, right?
      thanks,
    • By dblbassdrumer
      [ame]
      [/ame] only when u pull back in the clutch does it make this noise and wanna take off
  • Recently Browsing   0 members

    No registered users viewing this page.


×