Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Sign in to follow this  
quadcrazy

2005 Arizona ATV Jamboree Highlight

Recommended Posts



Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Similar Forum Topics

    • By Jacob Gentz
      I have a 2005 Arctic Cat 500 with a susuki motor, 2500 hours.  I was riding it yesterday, came out this morning, will turn over but no start.  I have spark and fuel.  Took carb off and cleaned it.  Back firing out of exhaust and air intake.  Not sure how one day it runs but 12 hours later it won't.  Just need some pointers on where to look.
    • By StolenATV
      Toy Hauler was stolen out of storage unit with all of our toys and items in it. We just rebuilt the engine and have only rode it once since. Please help
      The post Stolen Green 2005 Kawasaki KX400 appeared first on Stolen 911.
      View the full article
    • By quadcrazy
      If you are a new member, why not introduce yourself? This community thrives and grows with you and all our current members! We all want this community to grow and encourage new member registrations. That being said please help out QuadCRAZY by inviting other atv'ers to the community.
      QUADCRAZY NEEDS YOU!
    • By auditorguy
      Hi all  My sportsman 800 starts and runs fine but the idle is too low so it won't stay running even when it is all warmed up.  I know there has to be an easy adjustment to this but I cannot find it in the owners manual.  Anyone know how to adjust?  Thanks
    • By HeWasRidinDirty
      Hello all. I got this yzf for almost nothing. It's in pretty good shape. However, it's pretty stubborn on cold start-up. I noticed while cranking it over that there was water dripping from what appeared to be the exhaust where the pipe bolts on. It did fire up and I could smell coolant in the exhaust. The P.O has installed a toggle switch for the cooling fan. I'm thinking that maybe it overheated and cracked the head or something? Any tips/ advice is much appreciated. 

       
    • By Alex Mares
      I just purchased a 2005 Suzuki King Quad from Craigslist, it's in excellent conditions but me and my dad are new to ATV's, were first time owners. I wanted to see if someone could tell me the steps into changing the oil on the ATV and what kind of filter I am supposed to buy and also the recommended oil type/brand.
      And if you could give me any kind of tips to keep the ATV long lasting and what other things I need to change regularly rather than just an oil change, that would be great too.
      The ATV we purchased is the 4x4.
      Thank You!
  • Similar Tagged Content

    • By LMI
      Was using the quad the other day to shuttle wood from my pickup to my wood pile.  When the job was done I turned off the Quad and heard a bit of a racket from the front end.  When I got down underneath the sound seemed to be coming from the fan housing.  fan was moving in spurts and not quickly... much like a computer case fan that's had it's day.  What I know.
      Temp sensor is ok, as the fan tries to activate fan is getting some voltage as it is attempting to spin.  When I first bought it used I tested the fan direct to battery and it was fine. The fan was working ok even not direct wired as I went on a couple of rides and when stopped and idling the fan did run Seems to be free spinning with my finger read up in the manual and they require me to drop the rad.  now I'm not opposed to that as the rad has some damaged areas I want to try and straighten out.  But if I can get the fan working without, I can leave the rad as it is until next year.
      Fan assembly is about 300 bills, any work arounds or alternatives?  I even thought large computer case brushless fan.  smaller ones are about $7 larger ones better quality probably far below the 300.  They run standard 12v DC.
      Anything I should be doing before dropping the rad... other than check for obstructions even though it seems to spin, and trying to hardwire it to the battery again for a test to see if it acts the same?
    • Guest Fox300exchic
      By Guest Fox300exchic
      The Hop-Up: You may be saying to yourself, “that’s a chick bike,” and you’re right. But honestly, it’s so much more than that. It’s one badass bike. http://www.quadmagazine.com/quad/features/article/0,24942,1587044,00.html
    • By gregj49
      Blows out black smoke when you rev it up how do you adjust the carb?
    • By buzzar56
      I am looking for a free repair manual for a 2003 Polaris sportsman 500 ho atv. all the posts on here lead me noplace
      thanks fred.
    • By izzydum1
      Any ideas on what would make a coil not fire? She was running fine, then began slow start. Now wont start at all.
  • Recently Browsing   0 members

    No registered users viewing this page.


×