Quantcast
Jump to content

  • Do you own an ATV, UTV or SxS? Join our Community Forum!

    QUADCRAZY ATV Community and Forum are FREE to join! We keep our ATV, UTV, and SxS forums clean and user friendly. All first time posters in our forums will have to wait to have their content reviewed and approved. Once your first ten posts are approved, you will no longer need to go through a forum post approval process. To bypass the approval process with immediate access and a NO ADS experience in our ATV, SxS, and UTV forums, consider subsribing to a Premium Membership

Recommended Posts

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Forum Topics

    • By 97kingquad
      I have been rebuilding some ATVs in my spare time and teaching myself along with the help from the internet how an engine works and getting bikes running again is quite enjoyable. I even built an arctic cat 300 4x4 from two parts bikes the had seized motors and missing parts. It was pretty enjoyable. 
       
      So I am now working on a sazuki quadrunner 300 1992 which had a whole list of issues when I got it. I have fixed almost everything I need to in order to get this bike running. But something is going on inside the head or crankcase. 
      I had to replace the timing chain because it was very stretched due to the previous owner.
       
      What the issue was, the timing chain was off the sprocket inside the engine due to it being stretched it slipped off. So the previous owner rebuilt the top end thinking it would fix it which it may have temporarily, but when doing so they welded an extra inch onto the tensioner to hold the chain tight. Which as you can imagine caused a dozen other issues.
      So that stretched the chain to the point where I could remove the cam with the tensioner in.
      It beat the sliders all to hell. Destroyed the cylinder housing and obviously ruined the tensioner. 
      I didn't realise all of this until after I rebuilt the engine.  I noticed wear where the timing chain runs through the cylinder. I found the cam had no retaining chair, or clip whatever you want to call it so the cam was beat to sh** also. It had almost an inch of play side to side.
      So I pulled the head off of my parts bike and fixed all of it. Then put it together and went to pull it over and found it was not on the sprocket (this is when I realised that all that damage and the welded tensioner was because the timing chain had been off the sprocket) 
      So I pulled the stator cover off and pulled the flywheel (which I should add to get at the stator cover I have to remove the rear tire and a arm as well as remove the bolt through the front of the engine. And the exhaust system has to be removed to pull the cylinder as the exhaust guard is bolted to the side of the timing chain tensioner. Stupid setup. Glad the king quad doesn't have that. 
      So I got everything apart and the flywheel off. New timing chain (nice and tight now) put the head back together and flywheel but it is quite hard to turn the engine over. I can but with difficulty. When the valve cover was off it seemed to spin much more freely. Before I tear everything back apart and start again any ideas on what it is? 

    • By Toni82
      I am looking Servce manual for my BRP, can any body send me it on my e-mail? Please.... I think that it's will be a long hard wway to do this ( But i want to do this by myself.
      Please send on my e-mail: [email protected].
    • By Woodguy53
      When turning the ignition switch to start the machine, the console lights up but does not engage the engine (will not crank over).  I replaced the ignition switch, but have same issue.
      Thanks for any suggestions,
      Dave 
    • By PF3
      Rzr has been sitting unused inside garage for about 18 months. Engine started and run about 15 min every 1 or 2 months.  Never any problem starting or running. This week took it out of town to ride for a day. Loaded, unloaded with no problems. After unloading went trailing. After about a 1/2 mile we went down a small kill and started up another hill and engine died. Restarted many times and died each time after only free seconds. Brought it home and started several times with same outcome.  Changed to fresh fuel and started it.  Lasted about 90 seconds (at idle) and died. So we started it several times and revved the engine up and it continued to run (while still revved up) each time until we dropped it back to idle and it died each time. HELP! Please.
    • By jatho
      What is the best engine oil to use for the Suzuki King Quad - also any other tips and tricks I should know before doing an oil change on these bikes 
  • Similar Tagged Forum Content

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...