Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

MiBassman

Viper 3500lb Winch on Honda Foreman update

Recommended Posts

I want to thank everyone for the winch advise and suggestions. I ended up with a Viper 3500lb. The instalation wasn't to bad considering I've never installed one before. The wires were all color coded and their web site was very helpfull. I mounted a toggle switch under the seat so a kid or a novice rider can't accidently engage the winch. The winch works great and has way more power than I'll ever need. Any more power and I think it would stretch the frame. The only negative issue, and it's very minor; is the steel cable is a little too long. I'll be cutting off about 5 or 6 feet because it tends to bind up in the spool when almost fully spooled unless it's spooled perfecty even. Again, this is no big deal, the winch works great.

Thanks again to everyone who took time to respond when I asked for help.

Edited by Stoopidbot1
Wrong brand name

Share this post


Link to post
Share on other sites


Good to hear. How much did you end up paying? Did you buy it on ebay? Any photos?

I edited your thread title a bit, to be more descriptive..:wink:

Share this post


Link to post
Share on other sites

Ajmboy,

I paid $185.24 total from Moto Alliance web site. I called first to make sure it would fit and asked for the 5% discount. They were very helpfull and curtious. It arrived in about 4 or 5 days. I don't have any pictures, but it's snuggled away and still easy to get at for free spooling. It will hang my bike from a tree, and will pull trees out by the roots or break them off if I hook too high on them. It's already paid for itself twice pulling me out of muck holes in the swamp that were deeper than I thought. I'm very pleased with it.

Share this post


Link to post
Share on other sites
Ajmboy,

I paid $185.24 total from Moto Alliance web site. I called first to make sure it would fit and asked for the 5% discount. They were very helpfull and curtious. It arrived in about 4 or 5 days. I don't have any pictures, but it's snuggled away and still easy to get at for free spooling. It will hang my bike from a tree, and will pull trees out by the roots or break them off if I hook too high on them. It's already paid for itself twice pulling me out of muck holes in the swamp that were deeper than I thought. I'm very pleased with it.

Thanks for the update! I just checked out the motoalliance web site. Looks like they have some viper plows that are @ $400 with installation kit.

Share this post


Link to post
Share on other sites


"....any future plans for the atv???" Only future plans for it right now is to hopefully take a few deer out of the woods with it ! And perhaps a plow.

Share this post


Link to post
Share on other sites


I know this is an old topic. However I felt I should give an update. First let me say, in no manner, shape, or form am I in any way connected to or affiliated with Viper. I just wanted to give some feedback to Quad Crazy members for all the good advise I've gotten here. The viper winch is STILL going strong. I can't count how many times it's saved this old guys butt. (I'm now 68 yrs old) . Also I'm glad I got a 3500lb I wouldn't get anything smaller.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Eddie Rahm
      whats up fellas....the white wire going from the throttle body came unplugged from the circuit  board and im not sure where it plugs back in to ? i see where the red wire goes but im not sure where the white wire goes...im not even sure what those wires do..any help would be appreciated..thanks. 1996 polaris sportsman 500 4x4 push button awd.
    • By Andrzej Polak
      hi
      Where installing a winch to KINGQUAD ltf300?? someone have any pic?
    • By Awakzrx
      Build me a winch on my lakota
      Test it today
      Greetings from Belgium


    • By Azrial
      I just picked up a 2008 Kawasaki Teryx 750 LE 4x4 and am looking for Wench Suggestions. It was used by an old man to check his mail and only has 30 hours on it! I intend to use this on my very steep property like a small tractor. I had a old Ford 1220 Tractor and with its high center of gravity and lack of 4 wheel drive it was useless!

      To the point, I am looking a wench suggestions to help my new tool do its job! Even though the front bumper is drilled for a wench, I understand that I need a wench plate and that some wenches will not fit without body mods. Does 3500 Lbs capacity sound right?

      Thanks!
    • By w_r_e
      My scrap heap rescue '87 LT4WD has been running great until a couple days ago when the electric start started clicking instead of starting. Click is coming from the front so I got a new solenoid to try that (battery is showing 12.9 volts and is almost new so I doubt its battery). But like an idiot I pulled off the old wires without even noting what goes where.
      Now the battery cables I know, it lines up with the battery terminals. + on the right, ground on the  left if you're looking at the solenoid. But as for the the smaller wires that run to the starter switch, i have no clue. Help!
  • Similar Tagged Content

    • By sloundez
      Does anyone out there know where I can get a functional pair of wheel cylinders for subject ATV? Any suggestions welcomed. Thanks
    • By Racer944
      Hi Folks;
      Has anybody on here installed a winch on a 2003 Magnum 2x4? I am using a Cycle Country adapter plate (only one I could find), but am having a bit of trouble getting it all to fit properly, and am looking for someone that may have done this install and/or may have some pics of the installation.
      Thanks!
      Eric
    • By Npeters
      Im working on a old 1987 honda 125 4 wheeler in the school shop. It will start by getting pulled by another 4 wheeler but wont start with the pull start or Electric Start. When you pull start it it tries to start but when you try the electric start it just turns over but doesnt even act like it wants to start. The spark plug is dry and it shoots fuel out of the back(air filter side) of the carb. Weve had the carb off twice and it is complety clean. What are some things we can try?
    • By marcuslachance
      I
      I bought a Honda 250sx 1986 but the exhaust is broken. Apparently it's not possible to order a new one. I checked to order one on others compagny but there's noting.
      Do you know which exhaust it's possible to install. Is there a company who sold an exaust to fit on my 250sx.
      Sorry for my english
      Thank you
      Marc
    • By JenWal85
      Hope someone can help with this one.
      We took our 1984 Honda TRX 200 to the shop and they had it for about 2 weeks before they finally called and said that they had cleaned the carb and changed the battery and that it had started up.
      We went and got it and when we got home it would not start so we called them, they said bring it back in, so we did. They called us the next day and said they changed the spark plug, and that it was running. We went and got it again and it ran when we drove it off the truck.
      We parked it for about an hour because we were going to get ready to go on a ride. Well, it wouldnt start again.
      So we called them and they said the last thing they could do was order a new CDI box and put that on. I decided to just buy it myself, so I didnt have to pay them labor again. We put the new one on today and its still not starting.
      Does anyone have any ideas on what we could check to see what in the world is going on with this thing?
      Please and Thank you
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...