Quantcast
Jump to content

  • Do you own an ATV or UTV? Join our Forum!

    Join QUADCRAZY ATV Forum today for FREE! We keep these forums clean and user friendly. All first posters will have to wait to have their content reviewed and approved. Once your first post is approved, you will no longer need to got through an approval process. To gain immediate approval and a NO ADS experience, consider subsribing to our Premium Membership.

'03 Vinson 500 Auto - need help!


matbogbry
 Share

Recommended Posts

I have a 2003 Suzuki Vinson 500 Auto. I recently cleaned & rebuilt the carb, as well as, the petcock. Now it starts, idles and generally carburates well. My problem is that it will not rev out and only runs about 30MPH in high range. It runs smoothly from stop all the way up to top speed and it does not cut out, pop, or anything at full throttle. I am stumped! Any help would be appreciated.

Link to comment
Share on other sites

Dream Car Giveaway
  • 2 weeks later...

Thanks for the response. I did check the throttle cable and adjustment at the carb. I also check out the slide, which is raised by vacuum pressure. It appears to be sealed well and opening all the way. I took it apart and put it back together, being very careful to make sure that the rubber seal on the diaphram was seated correctly. Any other ideas?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...