Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

JasonB

2003 Suzuki ltz400 Cracked case

Recommended Posts

I have an 03 ltz 400 that has a crack in the left engine case right by the shifter. Wanting to know if that is a common problem with the motor? Thanks!

Share this post


Link to post
Share on other sites


It is a common problem on any machine that has thrown the chain. Check the shifter shaft for marks on the top that look like the chain has gouged into it, also check to see if the shaft is bent. I would recommend getting that crack welded up, if the part comes off completely, you will lose all your oil and I'm sure I don't need to tell you why that would be bad. Also, a good case saver will prevent things like that, and are a must on any chain driven machine IMO.

Share this post


Link to post
Share on other sites

what is a good case saver? Thanks for the reply!

Share this post


Link to post
Share on other sites

Most machines come with a half-ass sort of case saver, but they don't work that well. A good quality case saver is worth it's weight in gold. Here is a link to the ones that Rocky Mountain ATV has.

http://www.rockymountainatvmc.com/vehicleFilter.do?prevVehicleType=1&prevMake=7&prevModel=65&keyword=&vehicleTypeId=1&make=7&model=65&applyFilter=Change+Vehicle&year=2003&navTitle=Drive&webCatId=9&navType=type&webTypeId=68&uri=%2FtypeDetail.do

Edited by DirtDemon

Share this post


Link to post
Share on other sites
On ‎5‎/‎27‎/‎2010 at 7:03 PM, JasonB said:

I have an 03 ltz 400 that has a crack in the left engine case right by the shifter. Wanting to know if that is a common problem with the motor? Thanks!

Yes very common a lot of times the chain brakes if its not maintained properly. Or the shift shaft gets bent due to hard shiftig

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Gilbey
      I just bought a Sunl 2007 250 2x4 ATV and am going change oil in motor and rear end, any recommendations for products and instructions, as I have no owners manual. Oil is probably pretty simple and am guessing rear end is pump out and refill. Some specs would be nice to amounts of fluids.
      Thanks.
    • By ronwv48
      Just got a 2001 300 2x4 Bayou that needs a shifter shaft. Is this a very hard replacement to do? What do I need to watch for? Is there a video on this repair?
    • By Brantley40
      Anyone out there spice up their 2002 Kawasaki Lakota Sport 300 with cam, shaved head, deck the jug, valves?
      As you probably have already seen, I have a top end to get built back up and might as well add a little kick to it. Here's a pic of a golf cart I built up recently and modified the engine a little while I had it apart.
      Thanks in advance for everyone's help!!

    • By torck
      Hi, Guys. 
      Sorry for my English, I live in Ukrane, Kharkiv. 
      I have Can Am Renegede 800, 2007, g1, mileage is 430 hours. Happened issue with chain in first cylinder. Mechanic opened engine and found problems with piston, rings, cylinder, etc. So engine need full rebuild. 
      I found rebuild kit on ebay. https://www.ebay.com/itm/06-10-Can-Am-Outlander-800-800R-Stock-Cylinder-Crank-Complete-Engine-Rebuild-Kit/253868930525?fits=Make%3ACan-Am&hash=item3b1bc475dd:g:NdMAAOSwew5a-bY9
      Price is really good. For example original crankshaft costs $929.99. Here full kit costs $999. This kit made by BP Racing ATV Company. Here is their website https://bpracingatv.com/
      But I can’t find reviews to their products. My mechanics didn’t used parts from BP Racing ATV before. And their parts not very popular in Ukraine. I’m afraid that I will spent money for this kit + delivery + pay to mechanic for a work and will need new engine rebuild after 100 hours.
      What is the quality of parts from BP Racing ATV?
      Is it have sence to buy this kit, or pay more and buy original parts?
      Maybe someone used this kits for rebuild engine. And have expirence of using this parts. What will your mind about quality of parts from BP Racing?  
      Thanks for your answers.


    • By bradleyheathhays
      Have a '11 Crown Vic with 290k miles and I've been having a problem with the windows fogging up all the way around. The defrost seems to be working about half the time. On humid rainy days it'll work for say a half hour keeping the windows clear, then the windows will fog hard for 10-15 mins. And then it might decide to start working again, back and forth it goes. When I started it just now the compressor clutch turns when the a/c is turned on, although I haven't had a chance to observe it when the windows are fogging.


      A secondary problem it has is that it only blows air through the vents on the front of the dash, straight out into the cabin. The air flows only very weak out the defrost vent at the windshield or the floor. It does this on all settings. Although this might contribute somewhat to the problem, it seems like the a/c does completely cut out as the windows will still fog hard with the a/c set to on and on full fan. When it cuts off the air in the cabin feels immediately humid. One that that helps somewhat is to turn the temp toward cooler and it seems to not fog as much and gives it a chance to maybe clear the fog some.


      Any idea what's causing this or what I should do to start testing?
  • Similar Tagged Content

    • By Chayse Hill
      I have a 2003 LTZ 400 that i bought a few days ago. The quad was running fine until last night. I let my brother ride it down the street and back and i didnt notice anything etong with bike. Then my neighbors friend came over and said "can i ride it?" I said "sure" so he ripped it down the road all fine and when he got back it died right in front of us. My brother said it was dieing on him also. He also said that he wasnt using the clutch to shift. I told him he was an idiot. Im throwing that in there incase that caused a problem as well. But today i go to check it to make sure its getting fuel which it is and replaced the spark plug incase it wasnt getting spark but it is. So i started it and it was having a problem starting then i got started and was reving at idle high. So i took it around the block and it died on me a little bit down, so i try to restart it and it started so i kicked it into 1st and it kinda launched on me and started going with the clutch all the way in. Then it died right after and wasnt running right during that process and was idleing all over the place and just died and now i cant get it started it again. Before it would start without the choke or priming it. It would start real quick now i cant figure if it needs to be rejetted or something else. Air filter looks clean also. But any help would be gratelly appreciated!
    • By Jers
      I need to know what I have and what tire really go on it, Mine has 24x11x10 on the back and 22x8x10 on the front and I need new tire but I don't think are the right size. Also I can't find the model number listed but it looks like a 250 quadrunner 2wd and I think it is a 1987 maybe, can anyone help me, also I it has a rich running sound and I put a carb diap in it and cleaned the carb. is there a jet needing replaced?
    • By Racer944
      Hi Folks;
      Has anybody on here installed a winch on a 2003 Magnum 2x4? I am using a Cycle Country adapter plate (only one I could find), but am having a bit of trouble getting it all to fit properly, and am looking for someone that may have done this install and/or may have some pics of the installation.
      Thanks!
      Eric
    • By Wonderwoman
      Hello, well back to where I was last year with this carb. Took my 250 to the mountains for the first time this year and blue smoke, too much gas again. I can't believe that this carb gives me this much trouble. Seems like the choke is stuck but the cable moves freely. Anyone else ever experience this issue? Do you think a new choke cable would maybe resolve this?http://www.quadcrazy.com/atvforum/images/smilies/arghh.gif
      OK it was the choke. Put on all new cable and plunger and she is running 100% again. So now the question is, is the carb getting worn out where the plunger needle goes in the small hole and when I use the choke the needle end doesn't get lined back up with the hole?? We'll see how it runs and now that I know what the issue is I can always pull the choke plunger out and reinstall if I start having this issue again.
    • By davidwestfall
      looking for direct shift shifting lever that properly fits my 2003 Yamaha warrior 350 and fits my foot the same as a stock 2003 Yamaha warrior 350 shifting lever fits my foot
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...