Guest Fox300exchic

Squeeky Shocks

10 posts in this topic

Can someone tell me why my shocks are squeeking and what to do about it? I've cleaned them and it didnt do any good.

Share this post


Link to post
Share on other sites
  •  Like what you are reading? Please help us by sharing this content.


I think you will find that it isnt the Shock itself but the Rubber Bushings in the Shock Mounting points....Or,,,If it is Prevelent in the Rear of the Bike it could be your Swinger Bolt Bearings or the likes...Hope that Helps....

Share this post


Link to post
Share on other sites
  •  Like what you are reading? Please help us by sharing this content.

Yea, what MWKE said. Just take the mount bolt out and put a little grease in the shock eye, and put it back together. The same thing can happen with the steering stem mount.

Share this post


Link to post
Share on other sites
  •  Like what you are reading? Please help us by sharing this content.

We tried that too. Forgot to say that. Thanks. What next? lol

Share this post


Link to post
Share on other sites
  •  Like what you are reading? Please help us by sharing this content.


Yea, what MWKE said. Just take the mount bolt out and put a little grease in the shock eye, and put it back together. The same thing can happen with the steering stem mount.

^^ THIS ^^

Share this post


Link to post
Share on other sites
  •  Like what you are reading? Please help us by sharing this content.

WHERE is the Squeeking coming From???? Front, Rear,, All Around??? How about your Swingarm Bolt....Did you pull that and Check your Bearings???? Grease them??? If Grease doesnt help them then I would say order some New Bushings and it wouldnt hurt to order new Swinger Bearings if your going to go as far as Removing the bolt.. Other than that I dont know what to tell ya..:P When you do all this,,,,Just be sure to hold your Tongue Right and everything should be fine.....This maneuver usually helps mebiggrin

Share this post


Link to post
Share on other sites
  •  Like what you are reading? Please help us by sharing this content.

It's the front. We did grease everything and it still squeaks.

Share this post


Link to post
Share on other sites
  •  Like what you are reading? Please help us by sharing this content.

Ok,,,,,

Did you happen to notice anything like this????

squeak.jpg

If so you need to get yourself Something like this.....

Rentokil%20Mouse%20Trap.jpg

However,,,,Seeing that you are still experiencing this problem you might have something like this little Guy lurking.....If this is the Case I say you just might have to live with the Squeak.....

250835204_ac3b983abf.jpg

Share this post


Link to post
Share on other sites
  •  Like what you are reading? Please help us by sharing this content.

ok Something happen to the post I made a few minutes ago...It didnt even show up. Seriously though..the sound is annoying. thumbdown

Share this post


Link to post
Share on other sites
  •  Like what you are reading? Please help us by sharing this content.


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  •  Like what you are reading? Please help us by sharing this content.
  • Similar Content

    • By Corbin_Baker
      I'm selling (2) full sets of YFZ450R shocks, fronts and rears, all are in very good condition.
      $180 per set of 3
      Located in Ravenna, OH
      PayPal ready
      Please call/text Corbin at 330-931-8444