Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

rbstern

New to me King Quad 300...year???

Recommended Posts

Howdy, all.

Just traded my way into a King Quad 300. The person I got it from said he thought it was a 1998. Any way I can tell for sure? Want to get a service manual for it, but I know Suzuki changed some stuff in 1999. Want to get the right manual.

Also, fairly certain the motor is going to need an overhaul soon. Smokes pretty good, oil smell in the exhaust. Any reason not to do it myself? I am comfortable with small engine repairs, but know nothing about this particular motor.

Going to be using this to maintain some acreage, light trail riding, and for hunting. Looking forward to participating here. Seem like a really good resource.

Thanks in advance for any insights.

Share this post


Link to post
Share on other sites


Try to find the VIN number on the frame or on a tag somewhere.

Share this post


Link to post
Share on other sites
Any luck?

The quad is at my cabin, so I won't see it again for another few days.

Bought some brake pads to do the rear brake, have a small to do list of things to check, but will get the VIN, which is apparently on the rear of the frame from what research I've done so far.

Thanks for the follow up.

Share this post


Link to post
Share on other sites

sent a couple links for your manual to your email here. 1987 - 1998 Suzuki Quad Runner 250 King Quad 280 Service Manual Repair and 1999 - 2004 Suzuki King Quad 300 Service Manual. should be all set ....

Share this post


Link to post
Share on other sites


Thanks for the helpful comments, everyone. Turns out it is a 1994.

I'm in the middle of replacing the rear brake pads, and having some trouble getting the axle back into the bearing. Will post separately about that.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Kevin Nicoll
      Anyone familiar with these models? Its a new to me quad, picked it up for basically nothing... Just time and materials now, this looks expensive. 




    • By John Dunn III
      Just bought a LT 230 anything I should watch for. It runs and drive good. Just don't want no surprises 
    • By mrfartsalot
      I have a 2001 suzuki quadmaster 500 4x4 automatic and i was wondering witch atvs it shares parts with i know it shares some with artic cat. Any info would be helpful.



    • By oxidized_black
      Clymer ATV Manual - Yamaha Raptor 700R
       
    • By KINGSIZE
      Howdy,
       
      I was given a 2008 Yamaha Timberwolf by my in laws a few weeks back. Of course my FIL said it hasn’t run in 8 years but all it needs is gas and oil!
       
      That hasn’t been the case...so far I’ve replaced the spark plug, changed air filter, replaced battery, replaced fuel and oil filters, fresh oil and gas. I tried starting her up and no luck, it turns over but won’t get going.
       
      Now I’ve moved on to cleaning the carburetor which I’ve heard is a common problem area. I can’t figure out how to remove the bowl at the bottom, any suggestions? I removed the four screws that I thought were holding it in place but the bowl won’t budge
       
      Thanks and looking forward to getting her running!
      Some photos of what I’ve got going on , this has taken over the garage




  • Similar Tagged Content

    • By Ashton Crawford
      Hello everyone, i have 2000 Polaris Trail Blazer 300 I’ve been stumped on for weeks. I’m having a lot of issues starting the quad. I cleaned the carb spotless because I thought it was a carb issue and bought a new fuel line because it wasn’t getting fuel. The carb gets fuel perfectly fine now but it won’t start. The spark plug I a little worn out but it’s good enough for just one start. The only time it does “start” is when I spray starter fluid into the carb. But it never stays on. It’ll start for a bout a second then just die out immediately even if you’re giving it some throttle and the choke is on. I have no clue what I should do. If you need more information, have questions, or have any slight idea what the issue would be and how I could resolve it. Please reply ASAP. Thank you.
    • By Alan Callison
      OK ya'll.My son bought this thing and was told its a Kaw Bayou 300. Maybe. I cant find any numbers on it.The one tag I did find its so faded as to be unreadable. Its a long shot but maybe someone can help ID it. Thanks in advance.









    • By Jeff Wharton
      I have a 2000 Arctic Cat 300 4 wheeler. I have been having some carburetor issues. So i bought a new carb. Now I'm having these issues. The unit will start and idle fine, when i go to accelerate it wants to cut off. So i checked to make sure it was getting gas and the fuel filter will be full of gas and then once the carb opens the filter drains down and will not refill quick enough to run. So i checked to make sure gas was flowing to the filter and it is flowing fine through the line. I remove the filter and run the gas line directly to the carb and the engine idle fine and then it will run good as i ride it for about 10 minutes then it will start with the same issues again i cannot accelerate enough to move the 4 wheeler. Every time i accelerate the unit will cut off. What is wrong with this thing. My 400 Arctic Cat is doing the same thing except it will backfire, I'm lost i have tried everything i know to do, what am i missing here. Thanks for your help
    • By Maurais
      I’m looking for new replacement shocks (front & rear.) on my 1997 Kawasaki Bayou 300 2x4. New OEM shocks are upwards of $400. I haven’t pulled the rims off to check the eyelet to eyelet length but I’m hoping an expert on this site does know( I called Kawasaki direct yesterday and they were of know help.) Any technical help would be appreciated. TY fellow members. Vic
    • By scottj11
      Hello, how are you'ns doing? I'm in the process of tearing my Kawasaki Bayou down to fix a rattling noise and an oil leak. I'll probably be asking questions about this project. My step-son has an Arctic Cat 300, he was riding yesterday and when he turned it off it was running fine, but it won't do anything. The lights come on but it won't turn over or anything. Does anyone have any ideas on what might be wrong? TIA
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...