Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

New2Quads

1999 Suzuki King Quad 300 - Rear U~Joint Removal

Recommended Posts

Hello everyone!

I just picked up my first quad a couple of weeks ago- a '99 King Quad with a blown motor.

I mean blown to bits, probably about half the piston was gone. It looks like the exhaust valve broke and rattled around in the engine for awhile.

So I bought an engine out of an '01 and dropped it in, went incredibly smooth.

The new engine did not come with drive shafts so I started pulling mine off my old engine.

The front one came easy enough but the u-joints in the back appear to be peened on instead of clipped.

Do I need to grind the peening out and then press the u-joint out or ?

Thanks!

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Dra O
      posted a while back - it was running at one point - I have all the plastic shroud off - it's down to frame and engine now
      -fuel pump: when line from petcock is attached, no fuel comes out other side to carb; the line to the carb is open (can blow through it); I thought when I cranked engine that the pump would spit out fuel on other side but it does not; I removed fuel pump and opened it up - diaphragm looks good - but internal areas had lotsa calcification build up - I cleaned this out and dried it good - the clear plastic pieces (?diaphragms) aren't broken - the spring w/ steel ball on end moves freely; am putting it back on tomorrow; but can anyone answer about the pump? isn't it supposed to pump fuel through it... to other side... to carb? puzzling
      -along with fuel pump: I replaced petcock 3 weeks ago (gas tank had rusty fuel in bottom - cleaned it out prior to new petcock); when I turn petcock arrow NOT to on or reserve, fuel comes out of line; when I turn it to on or reserve, fuel doesn't come out; puzzling
      -I don't know what's on back of fuel pump - it's a valve that has a hose coming out of it - looks like it goes to engine/carb - I haven't traced this out yet - what is it?
      -can squirt gas on air filter and engine will run for 2-3 seconds then stop - fuel in top of carb (under diaphragm) does same
      -it likely needs carb rebuild - will get to this - but something isn't allowing fuel to get from fuel pump to carb
      -I THINK it has a mikuni model x carb - diaphragm is ID 26mm  OD 68mm - hard to find inexpensive diaphragm, I guess because it's a model x
      -last thing - I replaced solenoid due to old one clicking; I HAVE to be charging the battery or it won't start/turn over - battery just goes dead; but if charging, it'll turn over nicely; i'm guessing it's a bad battery
      -any help appreciated - I've never owned an ATV before - inherited this beast from grandparent in-law
    • By pablo Blake
      Its in pretty rough shape and its gonna be my first atv, I worked on bikes before but nothing to do with quads. Anyways the quad has some problems and im tryna figure out what to focus on first. So the U joints i think are shot. The bike starts first try every time ussually have to give it a lil gas with the throttle and revs right up, idles fine but its running REALLY rich 3 starts and my brand new plug was pitch black

      Bike is L model

      video-1577465068.mp4

      Its using the original mikuni carb but im not the best at fixing the carbs and wondering if there is anywhere online that would be able to either walk me through it or help me with it i didnt see a air mixture screw so it seems like im gonna half to open it up and adjust like the float and a couple other things
    • By Ed Zeppeli
      Hi,
      Oddly I'm having  a hard time ordering front brake shoes for my '98. 
      I'd appreciate recommendations on decent, widely available shoes if possible. Ideally available in Canada on short notice.
       
      Thanks much,
       
      Warren
    • By spavin
      Hi has anybody had a problem with a blown fuse near the battery box on this model ,causing all the electrics to go dead
  • Similar Tagged Content

    • By arvellaspoon
      When I push down on the rear brake pedal, it makes the left hand brake very sloppy. Is there a way to adjust that? I have a 2007 Suzuki Vinson
    • By chuckcnm
      Hi, just picked up a MOTO 4 YFM255 and want to replace the rear brake pads. How do I get to the back. Guessing I need to remove the brake disk, question any easy way to do this?
      Thanks
    • By Kyboy
      Iam looking for help seperating the rear brake drum and the cover. Any suggestions would be greatly appreciate
    • By dctaz37
      My ATV started making a rubbing and clunking noise. I took the skid plates off and found that the front u-joint on the shaft that connects the front axle to the transfer case is toast. My manual does not reference this repair. Looking for instructions.
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...