Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Shady

Hi from New Mexico

Recommended Posts

Hi everyone, I just got my first quad, a Suzuki 2003 quad sport 400. Last week it got stolen. :frown: But, my hubby found it and did a quick repo on the person who had it. Now there is so much work to be done on it, I don't know what they were doing, but they fucked it up. Oh well, it will keep be busy.

Share this post


Link to post
Share on other sites


Thank you. We stadted checkong the basics. Right now we are on the gas lines because now it wont start and the gas don't seem to be flowing like it should. They tore out the ignition and replaced with, a mail lock, like from a p.o. box, because the key to start it is a post office box key. *sigh*

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Ajmboy
      View File 2003-2004 Yamaha YZF450 Owners Service Manual
      2003-2004 Yamaha YZF450 Owners Service Manual 
      Submitter Ajmboy Submitted 06/02/2020 Category Yamaha ATV  
    • By swensy7
      Hey all new to the forum.... We ended up picking up a 2006 Suzuki z50 quad sport and took it camping this weekend. The guy said had a new top end and just put on a new belt. Seem to work fine for a little bit and then it lost power at the rear wheels. Belt was not in bad shape took a look but it just did not seem to have enough power to get my little guy moving. I pick up the rear end tires would go. Set it down lacked all power.   Any help would be greatly appreciated it did run like a top also.      To add to the bad news on the way home I ended up losing the seat so if anybody has one even if it's in rough shape would love to get it or if you have any ideas open to suggestions......
    • By Aleksandr Boreesenko
      doesn't idle at times but sometimes when it does as soon as I touch the throttle it just shuts off, what could possibly be the problem? I thank you very much for any help, Thanks.
    • By Ajmboy
      Got my Yamaha Grizzly buttoned up finally and went for a quick 2 hour ride in the power lines with my neighbor, who has a Yamaha Kodiak. We have access from his yard, which is nice. Was a beautiful day today to get out and will try to go more often. Ran into two other quad riders with a sportsman and I think grizzly. Also ran into a dirt bike rider. 😎




       
  • Similar Tagged Content

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...