Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Shady

Hi from New Mexico

Recommended Posts

Hi everyone, I just got my first quad, a Suzuki 2003 quad sport 400. Last week it got stolen. :frown: But, my hubby found it and did a quick repo on the person who had it. Now there is so much work to be done on it, I don't know what they were doing, but they fucked it up. Oh well, it will keep be busy.

Share this post


Link to post
Share on other sites


Thank you. We stadted checkong the basics. Right now we are on the gas lines because now it wont start and the gas don't seem to be flowing like it should. They tore out the ignition and replaced with, a mail lock, like from a p.o. box, because the key to start it is a post office box key. *sigh*

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Tagged Content

  • Similar Topics

    • By Abbeypalm
      While cruising, my 2011 750 king quad suddenly shut down. As it happened, red lights on the display flashed. Any ideas? My head lights suddenly stopped working about a week ago, if that helps. I have no power at all. Thanks 
    • By NathanFisk
      I have an 2003 Kodiak 400 Automatic and for some reason the starter not engaging I’ve replaced it still nothing it spins freely but not engaging. It was running fine the day before I am no expert so can someone please help me
    • By Brennon Heflin
      So I bought a 2000 quad runner 250. I'm having some issues an wondering what it could be I replaced the pet cock valve an the fuel filter an pump inside tank I also put a voltage regulator on it. The problem I'm having is that when u give it half or more throttle it bogs down an loses power what could it be the bike is almost like new an cant figure it out any help would be great
    • By smitht18
      Looking for the rectifier.  Most bikes have near magneto.  It appears the KQ has it in front.
      Can someone tell me exactly where it is? 
      Bike not charging and magneto checks out ok
    • By Hunter19
      How are you doing guys I just joined I have a 1998 Suzuki King quad I’m having problems with high RPMs the ATV idols perfectly but soon as a throttle up it doesn’t stall but it just bogs down it has no power any suggestions thanks
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...