Quantcast
Jump to content

  • Do you own an ATV or UTV? Join our Forum!

    Join QUADCRAZY ATV Forum today for FREE! We keep these forums clean and user friendly. All first posters will have to wait to have their content reviewed and approved. Once your first post is approved, you will no longer need to got through an approval process. To gain immediate approval and a NO ADS experience, consider subsribing to our Premium Membership.

Yamaha Timberwolf Electrical Problem - Electric Start and Lights Not Working


sirdivealot
 Share

Recommended Posts

Hi folks, I am new to this forum and signed up hoping to get some advice as to what the problem is with the electrics on my timberwolf.

The quad is a 2000 4x4 model, just bought it on the cheap a few weeks ago with electric start and lights not working. The starter makes no noise and no attempt to start whatsoever when the button is pushed and the lights dont work at all. It has a battery that has charge in it, so dont know why it wont just run off the battery, could it be a fuse?

I saw a thread on here about electric start not working on a timberwolf, I got some info from that but think this problem may be different so thought I'd make my own thread.

Any advice would be appreciated

Cheers

Link to comment
Share on other sites

Dream Car Giveaway

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...