Quantcast
Jump to content

  • Do you own an ATV or UTV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

2012 Suzuki King Quad 750 Feedback


Recommended Posts



Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Tagged Content

    • By Devin Heffelfinger
      Howdy
      So my stock 2017 750 KQ came with Carlisle AT489 Bias Tires
      On Amazon these seem to have excellent reviews although the thing I here the most cumulatively on the forums is the first thing to change is the tires. 
      Are these tires all that bad? They seem to be holding up nice and i go on some pretty serious black diamond trails. Granted this is my first ATV purchase and i don't really have anything long term to compare these to. 
      Please lace me up if im missing something here because if buying a new set of tires will increase performance - reliability- comfort - im all for it... Also if you guys could recommend some tires for the trails I'd appreciate it. I don't mud and don't plan to if that helps narrow down the search.
    • By oleskool
      have an 05 750, and she bangs out when you give it gas.
      Idles fine. Also the belt light is flashing, even after a new belt was put on.
      Any ideas?
    • By Jesper
      Hi guys
      Does anyone have a link to a service manual for the 2008 KingQuad fs 400 4x4.
      I would be very happy to get my hands on a file
      Thanks. :-)
    • By deadrider
      I have a kq 450 4x4 that I an have a problem with.the bike does not want to move.i am not very familiar with the sheave or clutch that it has on it.my buddy who owned it beat on it prolly never maintained it just so that's out there. The belt is fairly new primary and secondary clutchs are pretty ruff looking the rollers are toast I think but idk. Everything moves fine except for the primary it moves but does not push in to move the belt only at a high rpm will it move sometimes any clue on what it could be other then going out to spend 6 or 7 hundred on a whole new assembly of the clutchs
  • OEM Parts at Aftermarket Prices
  • Similar Topics

    • By tkokenos
      I just recently purchased a Polaris xpress 300 and have had a number of problems.. I purchased it in none running condition and found that it needed a top end done.. after completing the top end and not being able to find the oil drain plug for the engine, any kind of dip stick to check the oil, or any where that I could fill the engine with oil I was already frustated enough.. and then when i finally did get it started and tried to put it in gear and it would just grind(no matter what gear) My frustation has become monumental.. any help with this problem would be greatly appreciated.. i've already tried to idle the engine down to it nearly stauling out and then tried putting it in gear and it would just grind, or if i tried to force it it would just staul out completely.. for fear of tearing up gears I would like some input procede any further..
      Thomas,
    • By Lumberjack2
      I am fairly new to quads, but am mechanically inclined enough to work my way through engine issues. Transmissions/clutches, however, are a little beyond my understanding, and that's where I could use a little help today. I've got a 1998 Suzuki LTF500F I got for cheap last year, and with a little bit of tinkering got it running and riding. When riding it rolls through the gears just as smooth as you could ask for, but at idle and when the engine is off it's really difficult to shift, and sometimes it just won't shift at all. Looking through the manual I've found the clutch adjustment screws, but haven't really found any info to suggest how to adjust those screws to properly account for the issue I'm having. Any help you can offer would be greatly appreciated. Thanks in advance.
    • By lanow
      Hi Everyone,
      I am new to this forum and hope that someone out there can help me, I have an early Suzuki King Quad 300 (280cc) which starts intstantly every time but at about half revs or there abouts it starts spluttering and will not rev any higher, this fault is present whether choke is applied or not, some one suggested that silencer maybe be clogged so removed baffle but no improvement have removed carb and stripped 3 times but still no joy.
      Any ideas would be most welcome.
      Cheers Rob
    • By Puda
      I have 2006 king quad 300 keeps fowling plug any suggestions??
    • By Zmanyamaha
      Please help. Iv got an 1990 lt80 that will not charge the battery. I can’t seem to find the answer to the problem. Is it the rectifier or the Cdi box or something different all together. I can’t seem to find any rectifiers for it so I’m stumped and I don’t have a manual to read up and find the answer. 
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...