Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

Recommended Posts



When My Rubicon was new in '05

I could not find anything,So I did some fab work and

got exactly what I wanted :smile:

And if your not into this find a local welding shop:cool:

100_1232.jpg

Share this post


Link to post
Share on other sites

I also made a different bumper fit my quad. The one on mine now is from a banshee a friend of ours has. The new bumper I want also doesnt fit my quad. (go figure) So ill have to mod that one if I get it also.

Share this post


Link to post
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Anthony Marceau
      Hi everyone! I have a 1986 yamaha moto4 200 that's been sitting for a while! Cleaned the carb, replaced engine oil, put fresh gas in it. Got it running and went for a ride! It was running great just a little backfire once in a while! I barely made it home on the way back and now the bike won't run at all since then! It will start if I give a little bit of throttle but dies instantly as soon as I let go off the throttle! And even if I try to rev it up it'll sound like its not getting enough gas.. it revs up a couple hundred rpm's and backfires through the carb.. it almost sounds as if I was trying to take off from zero in 5th gear! Nothing is seized though! I dissasembled the head and the piston and cylinder are fine! Rebuilt the carb, replaced the ignition source coil.. I don't know what to do anymore.. compression test shows 90 psi Specs are 128 psi but i'm not sure if I trust my compression tester.. any ideas? Thanks!!
    • By bradleyheathhays
      I'm trying to put together a 3 night (Mon-Thurs) little get away and need some help finding a good location. Here's what I'm looking for...
      1) 2 days worth of easy mostly non-technical ATV trail riding (w/ passenger) with good look outs.
      2) Nearby camping with facilities that's not too crowded.
      3) Rental cabins close to the trail head.
      The first ATV park I know of is Black Mountain in Evarts KY. Lots of trails but I suspect they may lean more toward the technical side. Not sure about the cabin or camping situations in the area.
      The second is Ride Royal Blue just off I75 in Pioneer, TN. Good easy trails and cabins, but the camping situations I'm not too sure about.
      So...can anybody tell me about more locations w/in say 200 miles of Lex, KY that might be toward what I'm looking for?
  • Recently Browsing   0 members

    No registered users viewing this page.


×