Quantcast
Jump to content

  • Do you own an ATV? Join our Forum!

    As a member, you can post in our forums, upload your photos and videos, use and contribute to our downloads, create your own member page, add your ATV events, and even start your own ATV club to host your own club forum and gallery.  Registration is fast and you can even login with social network accounts to sync your profiles and content.

LTZ400IsLife

Suzuki LTZ 400 Stalling Issue

Recommended Posts

I recently purchased a 2005 Suzuki LTZ 400, for the first few days it ran like a champ but now when it gets hot, no matter what you do, it will stall out when you stop. Even going from 2nd or 3rd gear it still stalls out. It still runs perfect, it just stalls when I hit the breaks (hard or soft). I don't know much about quads so I could use some help.

Share this post


Link to post
Share on other sites


First you should download a manual for it if it's available on the forum here, or get from another online source.

How does it idle? Might consider turning that up.

Share this post


Link to post
Share on other sites

Check your air cleaner and spark plug. Make sure your carb air intake and outlet connections are secure. Beyond that suspect your carb needs to be cleaned or re-built.

Share this post


Link to post
Share on other sites


Suggest checking valve clearance too. You have a tappet shim setup which means you have to buy shims if it needs adjustment.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

    • By Ryan Foster
      I am trying to find a used OEM cylinder for the above mentioned quad. I was told the current cylinder came from Amazon so I suspect its aftermarket china (made from recycled coat hangers and shopping carts.) Anyway, was looking at the parts list and they have 2 cylinders listed..
      11210-19B82-0F0
      MODEL X/Y
      and..
      11210-19B90-0F0
      MODEL K1/K2

      My engine case is stamped K403 230829 Trying to figure out what model I have. I see I have a K in there but....
      I don't know what the differences are between the cylinders (the first one cost more). Anybody know how to decipher this?
      I only have the engine, I don't have the frame to get the actual VIN.  

      Also, are there any marks on an OEM cylinder to differentiate it from aftermarket?
       
    • By Frank Angerano
      So i took a road trip today to look at a Suzuki Eiger! 2006 in perfect condition other then the fact it starts for 30 seconds and shuts down.  
      Its been sitting for about a year in a shed. 
      It has a plow and a winch included!!!
      Got it for a really good price and all looks good so far.  
       
      Stay tuned.  





    • By Mike Hooper
      Hi everyone! I'm from New Zealand, and doing up a Suzuki Lt50 for the kids. This is the first bike I've ever worked on, and it's currently not running. Hoping that both Google and this forum will get me through! Haha

    • By dgk_mike
      It will go into neutral, 1st, 2nd, and reverse but nothing after 2nd gear. The shifter moves freely going up completely nothing but when you shift down it works. I’m not sure if it’s tranny issue worth messing with or if I should just buy a new one.  Overall besides that the thing runs like new.

    • By cliffyh
      Hi,
      Have a 2005 grizzly 660. Just recently started backfiring and showing incorrect speed. Lifted seat and messed with wire going to starter relay, it stops for a bit but seems to come back.
      I ended up pulling all the pins out of the connector for the relay and added new pin/connectors for all 4 wires. fixed it for a little bit but came back shortly after. This was a new starter relay i installed a few months ago. Anyone know if a bad starter relay would do this? 
  • Similar Tagged Content

    • By Wali
      I was riding my 400ex one day and when i shut it off to put it in the garage i tried to start it put again to drive it into the garge and it wouldnt start.I put a compression tester on it and its like 30 psi with out throttle and 0 psi WITH THROTTLE.
      when i put my finger over the hole it fell likes its pulling my finger in more then its pushing it out 
       
      Has good spark.When i took it into the shop the said it had 1oz of oil in it and a tiny pit of metal shaving(TINY BIT LIKE 30 flakes)
      When i try to pull start (push start/roll start) it made a not normal sound  and wouldnt stay running.
      If my bottom end is blow why would it still turn over fine,
      Are my valves siezed or not working properly 
      or is my timing off causeing valves to not open in correct order with fire 
      PLEASE HELP all help is appreciated 
    • By Hunter Aldridge
      Some times I get spark some times not can ride then it just dies and wont get spark it has new cdi box and stator but I don't know if it has the pickup coil I'm at a loss
    • By William Sims
      I have a 400 4by4 ,2005 green model,
      wounding how many different CDI boxes will work on it
       
    • By jerry houston
      Eiger 400 Suzuki runs fine Cook-Out joke face off the handlebars put it back on and will not start now will crank no no spark
    • By colin james
      View File 2012-2014 Polaris Sportsman 400 HD Service Manual
      This the factory service manual for the 2012- 2014 sportsman 400 hd service manual 
      Submitter colin james Submitted 02/08/2019 Category Polaris ATV  
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...